Warwick Grigg's picture

After I click on Appflower studio spash page and then try to login, I get "The username and/or password is invalid. Please try again." I'm trying to login as admin. I've tried the password I used when I created the container (in proxmox) , and the password "admin" and a few others.

I do remember the password I entered correctly: I can ssh as root with that password. I've also tried removing the container and creating it again with a simpler password.

I'm using the package debian-6-turnkey-appflower_12.0-1_i386.tar.gz on the latest Proxmox VE downloaded today (proxmox-ve_2.1-f9b0f63a-26). It my first time trying proxmox and Turnkey but I like what I see. 

Any ideas how to get past the login? Much appreciated.

Warwick Grigg's picture

Problem solved. Password is "turnkey" on proxmox which I found from posts for similar turnkeylinux apps on proxmox.  

Jeremy Davis's picture

The way TKL is designed, the init/setup scripts which regenerate security keys and set admin passwords run on firstboot. Due to the fact that OVZ appliances don't have a true terminal that approach doesn't work (the first boot scripts will run but there is no way to access them, so they cause things to hang). A workaround for that is that the autorun of the firstboot scripts has been disabled in OVZ templates.

So bottom line is that you need to run these scripts manually. It's as easy as 'turnkey-init'.

Add new comment