Franklin Bluth's picture

I'm running the latest LAMP stack on Amazon EC2.

I installed the time module in Webmin.

But when I go there it says "hwclock failed" on the main tab, and if I switch to the Change Timezone or Time Server Sync tabs, there is no content shown.

The server is on UTC whereas it should be on British Summer time.

Jeremy Davis's picture

In Linux, you want the system time to be UTC, but if you need local time info then you need to update the timezone (so that the system adjusts the system time/UTC for the benefit of your apps).

But assuming that you want to update the time then you should be able to follow this (note the pics aren't showing - the original post with pics is here - in Spanish though...).

Perhaps that is what you have followed already though? If so it sounds like the system can't get access to the hwclock (or simulated hardware clock as it is running in a VPS). Perhaps you'd have better luck following the instructions for doing it via the commandline?

Bo's picture

Steps to Solve "hwclock failed"

  1. Follow turnkey forum topic Configuring the timezone on TurnKey Linux to install webmin-time.
  2. Once webmin-time is installed, click System->System Time from main menu at top-left.
  3. Click "Module Config" from System Time menu at top-right.
  4. In the "Configuration" screen, under "For module System Time": "Configurable options for System Time": "System configuration": Set "System supports hardware time" to "No".
  5. Click "save" at bottom-left.
  6. Done.

Summary of Option Settings

Configurable options:

  • Acceptable number seconds of delay between system time and hardware time: 5 (N/A)
  • Default time server: (see other NTP's at: NTP Pool Server)
  • Only use NTP for time synchronization? Yes

System configuration options:

  • System supports hardware time: No
  • System time setting format: MMDDHHMMYYYY.SS
  • Timezone configuration method: Linux
  • Command-line flags for hwclock: None


Add new comment