Joel's picture

ran a backup before with no problem and it appeared in my hub account


Today, I ran a backup and it does not show up in my hub account.

I only run manual backups, so there are two backups in my hub account from Dec.

The one I ran today, it shows up in the Webmin log, but it isn't available in my hub account


Any ideas?

Jeremy Davis's picture

I have had experiences where they have been a little slow to show up on the Hub (I think it is when Alon does some behind the scenes Hub maintenance, but not sure...) Bottom line is though if you can see the backup from any of your appliances (either through commandline or Webmin) then all should be ok, and it's just a case of the Hub not showing them, not that they're not there...

Joel's picture

Thanks for that reply Jeremy.


Ok, here's what it says in Webmin, Backup ID1 updated monday...I'm guessing that's an incremental backup? or maybe it took a while to upload the 4GB backup so even though it started Sun. night, it didn't finish uploading til Monday? 


But when I click on Restore, it only shows the 2 backups (1 full, 1 incremental update) from Decemeber (the same ones that show up on the hub)

Joel's picture

It's still not in the hub account, I'll wait a few more days and see what's happen'n

Jeremy Davis's picture

When you are logged in to the Hub, on the left hand side there is a blue 'Feedback' button. I suggest that you post them a link to this forum thread and see where you get to from there...

Joel's picture

An update:


I never heard back from the Dev's via the feedback I submitted.

A bit more digging around and I wondered if there was a way to check what API key my TK app was using. I had previously done some testing of cloud servers on and the amazon cloud, before going with bare metal. Turns out, I had the wrong API key.


I saw in another forum post that

tklbam init --force 

could be used to reset the API key. I found the right key in my hub account and got it to work. Now, it says "first backup in progress" so we'll see. It's been 6 hours since I started, not sure how long this takes to upload from a data center to S3. It's only 2 GB.

Jeremy Davis's picture

Usually the devs ae pretty responsive to isues posted via Feedback. I guess it doesn't matter now though as you seem to have resolved it... FWIW assuming that your upload speed is somewhat similar to what we have here in Australia (1Mbps) 2GB would take min of ~5hrs - assuming that the full upload bandwidth is completely satuated 100% of the time. Obviously that's not realistic nor likely so probably more realisticly something up to twice that is not unreasonable...

Joel's picture

Once I got the API key's to match on the TKL app and in Amazon, it was good to go.

Thankfully, the TKL app is running in a data center so the upload speeds to Amazon are speedy. 2gb took 2 and half minutes :-D

Jeremy Davis's picture

That's sweet! Glad you're all good to go now! :)

Add new comment