Henry den Hengst's picture


I would love to change the language of the vtiger 5.4.0 appliance to my native Dutch language. I found the language package, and read the documentation on https://wiki.vtiger.com/index.php/Installation_How_To%27s#How_to_install_language_packs.3F

Afterwards, modify the config.php file present under vtiger CRM Home and add the following for $languages array.

and then the config.php states...
 * The configuration file for FHS system
 * is located at /etc/vtigercrm directory.
and then I check out if that folder even exists /etc/vtigercrm and its says...
root@vtiger www/vtigercrm# cd /etc/vtigercrm
-bash: cd: /etc/vtigercrm: No such file or directory
Can anyone help me turn this appliance from English into Dutch?










Jeremy Davis's picture

According to the vTiger appliance page it is installed from upstream to /var/www/vtigercrm so that would be the first place to look for the config file...

From my reading of the links you provided if you have edited config.php (config.inc.php? - I'm not sure which as it mentions 2 different filenames on each of your links...) then you should be able to select your language from the login page.

Henry den Hengst's picture

I edited the config.inc.php as described in the howto. Only editing the the config.php is not possible due to what I described. I put a login screenshot and a after login screenshot in the current situation. Try to configure your vtiger with a languagepack of your choice to see what I mean, that way is easier to help. Thanx.

Jeremy Davis's picture

It is there alongside the config.inc.php (in fact it is the config.php that you quote from: "The configuration file for FHS system is located at /etc/vtigercrm directory" - but this is obviously not the case because it is in the same place as config.inc.php and there is nothing in /etc/tigercrm...)

But anyway that is completely irrelevant anyway.

I had a bit of a further read through your links and discovered that that page you linked to is very out of date (it refers to vTiger v4.x, not 5.x). That wasn't completely obvious at first (although the first thing that lead me to think something was wrong was the fact that the $language variable doesn't exist in config.php or config.inc.php) but a little further down it mentions v4.x...

So a quick google turned up the currrent documentation (https://wiki.vtiger.com/index.php/LanguagePack). You can read it yourself but it is all done from within the GUI now. From the setting menu it involves installing the module (the zip file that you have already) and then selecting Dutch from your preferences menu. I have tested it and it seems to work fine (although I don't understand Dutch so I'm only guessing...)

Henry den Hengst's picture

Indeed, I found the wrong howto for version 5.4.0 ! Your instruction worked just perfect. Let me put down the part that did the trick... :)


How to install new language packs

1. Get the latest language pack of your language from the vtigerforge

2. Login to your vtigerCRM, go to settings > Module Manager ,click on custom modules here you will see a button Import New ,click on Import New and select the language pack which you downloaded from the vtigerforge and click on Import.

3. Once the import is done successfully you will get Finish .Once you click on finish the installation is done successfully

4. If you want the make the new language file as your default language then open the config.inc.php of your vtiger system and look for the line where you can find: $default_language = 'en_us';

change it to the following by using the language file name (example Dutch is used) $default_language = 'nl_nl';

The key name given in the $default_language, will be the prefix of the language files of your package. (here 'ru_ru' is the key name, therefore the Dutch language files will have the name nl_nl.lang.php, the same rules apply for other language packages.)

5. Now at the login page the default language will be shown in the first position .


the manifest.xml in /cache/manifest.xml should be edited to....


<?xml version="1.0" encoding=”utf-8”?>
<author>Vicus eBusiness Solutions bv www.vicus.nl</author>
 * Vicus eBusiness Solutions Version Control
 * @package NL-Dutch
 * Description Dutch language pack for vtiger CRM version 5.4
 * @author $Author: luuk $
 * @version $Revision: 1.2 $ $Date: 2012/04/22 12:18:52 $
 * @source $Source: /var/lib/cvs/vtiger540/Dutch/manifest.xml,v $
 * @copyright Copyright (c)2005-2012 Vicus eBusiness Solutions bv <info@vicus.nl>
 * @license vtiger CRM Public License Version 1.0 (by definition)

Add new comment