Jon Jagger's picture

 

Hi,
I run http://cyber-dojo.com (a free, no registration, browser-based coding dojo for 10+ languages with test frameworks) from a Small Turnkey server. 
I would like to make a backup of it so I've enabled S3 amazon backup.
However, Amazon is giving me a page that enables me to generate an Activation key.
 
Question:
Does this activation key need to be used to configure my Turnkey server?
I can't see anywhere obvious from the Servers page, but backups is still off.
Or is there simply a delay before backup is enabled? 
 
Question:
Can I clone a new server from the backup once I get a backup?
 
Turnkey is great
Thanks
Jon
Forum: 
Tags: 
Jeremy Davis's picture

It was so long ago and I think I set up servers and backups at the same time so I think I only one key. So bottom line is that I can't answer your question sorry. I suggest that you use the Hub feedback (blue button on the left when logged into the Hub) to contact the devs directly. You could point them to this post for detail (rather than writing it all again).

But once you have taken a TKLBAM backup then you can restore that to a fresh server and depending on your server config you can create a new server that is pretty much like your current one. Note thought that user data in 'naughty places' won't make it across (i.e. you need to follow the Debian FHS and not put stuff in places handled by package management). Also packages installed from non standard repos won't make it across automatically.

If you are using an EBS backed instance then you also have the option of AWS snapshots. Which AFAIK is more like a normal VM snapshot although I haven't used it and can't really comment on it.

Alon Swartz's picture

There might have been a delay with Amazon processing, so you'll need to re-trigger the Hub into verifying against Amazon again. Try this:

  • Make sure you are logged into the Hub
  • Go to http://www.amazon.com/dp-activate and click "Go to application" next to TKLBAM (you don't need the activation key, the Hub will get it automatically when you are redirected to the Hub)

Hopefully you'll see that TKLBAM is now enabled.

To re-iterate what Jeremy said, yes, you can restore the backup to a new server (under the Backups tab, you'll see an option to "launch this backup as a new server". Snapshots and cloning the server are also possible if you're using an EBS-backed instance as Jeremy mentioned.

Kris's picture

Is Alon's link still a valid route to switching plans? I followed the link, clicked on 'unsubscribe old plan' and now I see both plans in my EC2 Account. Does the unsubscribe take a while to happen or do I actually have to do another step and cancel bronze from the EC2 account screen? I'd really hate to lose my data because I was impatient. It's been about 1.5 hours. I have a copy from the popup below--and I did click on the 'unsubscribe old plan' link. Feedback?

Multiple EBS-backed plans are enabled

According to our records, it seems you are subscribed to multiple EBS-backed plans, when only one is required.

  • Bronze plan (latest verification: Dec. 28, 2012, 6:42 p.m.)
  • Gold plan (latest verification: Nov. 6, 2014, 6:23 p.m.)

This is most likely due to a recent change in your plans.

Unfortunately we cannot automatically unsubscribe you from the old plan, as Amazon's billing system does not allow this from our end.

Old plan cancellation:

We recommend you unsubscribe from your old plan using the button below. Don't worry:

  • Instances you launched under your old plan will automatically be transitioned to your new plan. You won't loose anything.
  • As soon as you cancel the old plan, you'll get a pro-rata refund on the old plans remaining monthly fees.

If you've already unsubscribed from your old plan our records will be updated shortly and you won't see this notification again.

 

Unsubscribe from old plan

 

 

Jeremy Davis's picture

Personally I would wait longer than 1 or 2 hours (although theoretically it shouldn't take too long, sometimes it can be a bit slow updating).

If you go back to your AWS Payment page and look under Applications. If Bronze is still there you are still being charged for it. However keep in mind that as it is charged pro rata; 24 hours ~= 67 cents! So it probably isn't worth risking data loss for the sake of less than a dollar!

Kris's picture

Thanks, Jeremy. Related to slow updates, my webmin access has slowed to a crawl. I often can't get the log in page to come up in under 2 minutes and my browser times out. Any suggestions? I just rebooted my TKL server, but that didn't help. It may have made it worse. The app is running well, but even when I get into webmin, it can take 20 minutes to move to a new page. This is really weird.

Jeremy Davis's picture

I would suggest that you do some initial diagnostics to see what is causing the problem - RAM? CPU? Network throughput? Network packet loss? Do you get the same behaviour if you connect to Webmin from a physically different location? On a different computer?

If you keep in mind that TurnKey is Debian under the hood (v13 = Wheezy) then you should find plenty of info via google. Although in the case of Webmin, TurnKey package it and it is installed from the TurnKey repo. Although considering that no one else has reported similar behaviour I think it is probably something unique to your server.

That doesn't rule it out as a TurnKey bug, but makes it unlikely IMO. If you get stuck I suggest that you start a new thread detailing your server, what you've tried and what you've discovered.

Jon Jagger's picture

Hi Alon,

thanks to your help I appear to noe be running a backup :-)

Thanks

Jon

Jon Jagger's picture

The backup says it has been running for nearly 24 hours now...

Does it really take that long or has something gone wrong? 

Thanks

Jon

Add new comment