Vijay Tilak's picture


I had successfully tested vtiger turnkey linux in the local enviornment and used gmail server as outgoing server. It is working perfectly in local lan setup

I created hub account ... migrated turnkey to vtiger hub ( from local to Amazon )

now the outgoing mail is not going. I'm from NZ and the amazon server resides in Australia. As soon as the amazon server tried to access gmail from Australia, gmail blocked the request considering it as a hack. I recieved a notification immediately and i clicked allow and ensured that google allows the server request. But after that still the outgoing settings are not getting saved as the mail is not going.

Following is the error obtained when i try to save the settings : (the same setting works on the local copy of turnkey in the lan)

Test Mail Status : Mail could not be sent to the admin user. Please check the admin emailid/Server settings

Could someone please help me on how to get through this ?

Thank you

Kris's picture

I had problems with this, too. Might be the same problem. I had to edit the mail.php file and the post from Jose at this link was very helpful:

My issue was that email server sends test emails in loops and through port 25. Amazon shuts us down for exceeding our email limit. And port 25 is not preferred anyway.
 Here's the part in we applied after finding the file using the file manager (taken from the post in the link above):

 Re: outgoing smtp server illegal address syntax
  by Jose » Fri Apr 27, 2012 2:26 pm
 I solved this issue following these steps:
 1. Open /modules/Emails/mail.php
 2. Go to the function setMailerProperties
 3. Change the line:
 Code: Select all
 $mail->Sender= getReturnPath($mail->Host);
 Code: Select all
 $mail->Sender= $from_email;

Add new comment