Michel's picture


Right now I am using the Turnkey Linux Wordpress appliance with AWS/EC2 (Oregon - West USA) and the Public IP listed on the dashboard page is assigned to our launched server.

This is what our DNS is using for our domain.

Will this be the permenant IP address that will remain on this server or will it be auto-renew to something else?

If not, how can I assign a permanant IP address that doesn't change?  I'm asking because I seen a few google results where the IP has changed to something else and I don't want that to happen.

Thanks in advanced!


Jeremy Davis's picture

This is sort of the same answer to your other thread, but from a different angle...

Firstly, the public IP is not static and may change. So I have 2 suggestions:

1. Buy an elastic IP from Amazon, which is something of a static IP (but it is reassignable to different instances...). If you go this way then you'll need to configure your domain host to point your domain at your elastic IP (which is then assigned to the relevant instance).

2. Or add your domain name to the Hub and handle it through Hub DNS. Have a read here.

Michel's picture

Thanks Jeremy, so if I understand you correctly I need to get an Elastic IP address if I want a static IP assigned that doesn't change?

This is the option I would want since we easily control the DNS for that domain.

I figured it was an Elastic IP, but on the TKL Hub Dashboard with our launched server, I already created an Elastic IP (actually several because it wasn't working correctly) for the region my server is in (Oregon - West USA).  However when I click on "Associate existing" it gives the error:

Error associating Elastic IP '' (The instance 'i-2b29c41f' belongs to a VPC.)

I have tried other Elastic IP's that I created, but I get the same error.

Therefore, how can I assign one of the created Elastic IP's to my launched server without getting that error?



Jeremy Davis's picture

Someone else has recently lodged it, with a workaround! :) I also noted that you are having the same issue.

Michel's picture

Forgot to update on this one.

Yeah, manually adding the Elastic IP to the instance and it worked great. 

So there is something broken between TKL Hub and AWS EC2.

I prefer to manage everything for our EC2 instance from the TKL Hub, so I hope that is resolved soon.



Jeremy Davis's picture

But at least there is a workaround currently. Now that TKLDev is out I suspect that they may fix a few little bugs before they start work on the v13 appliance release...

Chris Musty's picture

You should get Amazon to configure reverse dns and no mail sending restrictions if you are sending email. 

Allot of spam filters will stop your emails cold if you don't. 

I am on a phone so can't easily find the address but just google 'aws reverse dns form'  and take it from there. 

Chris Musty


Specialised Technologies

Jeremy Davis's picture

BUt where exactly it ranks I'm not sure... I don't think the workaround is too involved (although obviously having it all available from the Hub is preferable).

Add new comment