The latest lamp stack is very nice, however, we are finding it impossible to disable whatever mechanism is caching the web pages. Sadly, this makes it useless as  a development server.

We have searched the apache docs, but found no solution. it may be some specific Debian or TKL setting? We need the server to grab the absolute current file on every request.

Any pointers where to look?

Forum: 
Nauseous's picture

I had same issue and it was apache2 disk cache which I disabled and resolved all my issues.

Login to webmin | apache | modules | disable cache and disk-cache

or

a2dismod cache ; and the same to a2dismod disk_cache


Vijay's picture

In php.ini file, try adding opcache.enable=0

opcache prevented me from updating php files.

Berk Teke's picture

Hey Guys i have tried both solutions from Vijay and Nauseous with no luck :(

i have no idea how and what in the server still caching my website????!!!!

I have a server as i cant use for developing :(

i will be really gratefull if someone can help me out of it.

 

Jeremy Davis's picture

Restarting Apache should always work. So:

service apache2 restart

Although obviously, if you're deep in development, having to do that regularly will be a PITA!

TBH, I'm not 100% sure, but it should only be PHP's opcache that is doing the caching, so disabling that should be enough. I.e. as Vijay noted, in /etc/php*/apache/php.ini, adding opcache.enable=0 should do the trick. You'll need to restart Apache (as above) to enable that though. To double check it worked, have a look at the php info (on TurnKey LAMP, browse to http://<server_ip>/phpinfo.php).

Also a quick google turned up how to disable browser caching which may also be a thing in your case? I haven't tested it, but here's some links:
http://bertanguven.com/disable-caching-of-assets-in-apache
https://gist.github.com/JamieMason/3245483
https://askubuntu.com/questions/868413/can-i-turn-off-php-and-html-caching-both-within-an-apache-virtual-host-conf-file

FWIW the default virtual host site on TurnKey LAMP can be found at /etc/apache2/sites-available/000-default.conf

Hope that helps. Please post back to let us know if it does!

Add new comment