Michael Nugent's picture

I can't connect to the internet, It does this at bootup, but when I manually configure in the configuration console, it connects. I reboot and it will not connect. It says:

Error Obtaining IP address

udhcpc (v1.17.1) started

Sending Discover...,

Sending Discover...

Sending Discover...

/usr/share/udhcpc/default.script: Lease failed:

No lease, failing

Failed to bring up eth0.

Michael Nugent's picture

Thanks for your help, Not that anyone helped anyways. I fixed the problems myself, So from now on when I need support, I'll bloody fix it myself because you arses won't help anybody anyways

Drew Ruggles's picture

I think the issue is if people are not willing to put forth due diligence toward investigating and effectively communicating the conditions they are experiencing, it's going to be very difficult for someone — volunteering their time — to do problem solving for them.

Case in point, there are no networking settings given in either communication above (let alone whether these are VMs, bare metal installs, AWS instance, etc or even what appliance we are talking about...?). Simple enough, you have a few very easy routes to take:

  1. Console — Look at your console, go to <Advanced Menu> > Networking and take a screenshot and post it up (TIP: if it's >670px, use the [ resize ] button to resize to 670px and be sure to check "create a new image"):
  2. Shell — Bring up Terminal and ssh to your appliance. Enter ifconfig either post the screen shot or copy > paste the text as "Formatted" style in CKEditor tool bar, above.

  3. root@pbtracks ~# ifconfig
    eth0      Link encap:Ethernet  HWaddr 08:00:27:91:57:49  
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::a00:27ff:fe91:5749/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:11674 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1182 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:855798 (835.7 KiB)  TX bytes:427741 (417.7 KiB)
              Interrupt:19 Base address:0xd020 
    lo        Link encap:Local Loopback  
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
  4. Go to Webmin > Networking > Network Configuration

Any of these will help people begin to troubleshoot your networking issue, but you gotta give a little...


Jeremy Davis's picture

Sounds like a classic case of no network to me... Personally I tend to use the 'bridged' mode (although not sure if that's what Fusion calls it?). It basically allows the VM to act as if it were it's own complete PC on your network. Or you could try 'host-only' at least just to test it I'm not sure about Fusion, but I know that VirtualBox has a build-in DHCP server for VMs that use 'host-only' mode).

Out of interest are you using the VMDK or installing from the ISO? If you're using the VM build, then perhaps there is something pre-configured that isn't quite compatible with Fusion? I'd double check all the Fusion settings and options. Perhaps compare them to a working VM... Also I've not had any experience with Fusion but most VM hosts allow you to adjust the virtualised hardware that is presented to the VM. Maybe try alternate vNICs (stop the VM, change the virtual hardware, start the VM) and see if that makes any difference.

Worst case you could try installing from the ISO (into a fresh new VM. That's a little more mucking around but should (at least in theory) be foolproof.

Michael Nugent's picture

My DSL Router was old and needed replaced, so my ISP sent a new one and I haven't had a problem.

Add new comment