Ron Fish's picture

I don't know how many of the vz images do this but so far i have found both django and web2py will run at 99% CPU utilization out of the box. I found a fix for it:

 

# service rsyslog stop

# sed -i -e 's/^\$ModLoad imklog/#\$ModLoad imklog/g' /etc/rsyslog.conf

# service rsyslog start

 

 

Hope this helps someone

Forum: 
David's picture

Thanks for this, worked perfectly for me. Using a Debian/Ubuntu VMWare VM on a shared cloud with openvz and had the exact same issue. Appriciated. 

Ron Fish's picture

glad to help!

Linux Admin Texas A&M University

Jeremy Davis's picture

I use OVZ almost exclusively (via ProxmoxVE) and can't say I've encountered this issue... I currently have a few (unadultarated) v13.0 TKL appliances running (under OVZ) although not the 2 you mention. Mine are all idling at about 0.5-1.6% CPU so not sure what is going on there...

Amine Hmida's picture

It works like charme !!! Thanks for the tip, you saved my day :)
 

LE's picture

I have been looking for a fix for a few days.. my server was working fine untill i accidently upgraded my old version or rsyslog (An erlier fix ws to just downgrade rsyslog). I tried to put the old version back on with no luck. the above fix worked like a charm!! thanks for the help!!

Jeremy Davis's picture

Not sure if this applies to you guys as well, but I have noticed that until you log in and run the inithook scripts (i.e. the ones that set passwords etc) the container will run at ~99%. After you have done the first login and run them then it settles down to normal.

The other possibility is that it is something with vanilla OVZ that has been patched in Proxmox (I'm running v3.1 currently).

Kyle Miller's picture

Doesn't this turn off kernel logging? Is that something you would want on?

Andre's picture

OpenVZ 4core cpu 1g ram - ubuntu 14.04

syslogd - 97% - htop = 25% cpu usage on all 4 cores

after fix, working great, thanks

 

achi's picture

this is not a fix, you are just turning off the log

Jeremy Davis's picture

However as I am not able to reproduce the issue I can't assist providing a proper fix...

Matthieu's picture

Seems doesn't work on Centos :(

NStorm's picture

Kinda old thread, new OpenVZ kernels doesn't suffer from this issue afaik. But more appropriate fix would be to install other syslogging daemon to replace rsyslog. Like syslog-ng (available in most distros). Which is better than to turn off kernel logging at all.

Add new comment