PumWalters's picture

fresh install of concrete5_13.0-1_amd64 on Proxmox VE 3.1. Upgrade C5 to latest. Then install a new theme.

The thumbnail for the installed theme just shows a 'missing image' icon, and all theme-images in the site are missing.

The link to that thumbnail is faulty: 


Links to built-in theme's thumbnails are ok:

The problem isn't in the theme: other freshly installed themes have the same issue.

Yesterday I did this on Proxmox 2.2, and thinking that was it I just upgraded to Proxmox 3.1, but the problem persists.

Any thoughts? Any success with installing themes on the latest C5?


PumWalters's picture

I've just tried this without any change whatsoever. That is: concrete5_13.0-1_amd64 on Proxmox VE 3.1, all out of the box. Installing a new theme just doesn't work, which suggests that the C5 installation isn't configured OK.


Any suggestions? Experience?

Jeremy Davis's picture

Although I would think that that wouldn't let you install your theme at all (I assume that you install through the UI!?).

I'll have to download and install it when I have time and have a look...

PumWalters's picture

since this is an out-of-the-box install of the appliance.

The theme-install through the UI works fine except that all URLs of images look like //packages/... rather than /packages/...

Jeremy Davis's picture

I have just installed TKL C5 v13.0 (OVZ 64 bit template into PVE v3.1). I couldn't test the theme you are using (because it's a paid one and I don't want to pay for it...) but I did test a number of others (Halloween, Lazydays & Natural Essence) and whilst there were some quirks to my eye they all seemed to be related to the theme itself (i.e. they weren't consistent across the 3 themes). The thumbnails all look fine on my install (and out of interest are all thubnail urls are like

How did you install the theme? I connected my C5 site to the community (via my C5 user account login) and downloaded and installed my themes direct from the marketplace (within my C5 server). Is that how you did it?

Also have you logged into your server via SSH (or even the PVE java console)? If not then you haven't finished initialising your appliance! 

Failing those 2 thoughtss, perhaps the particular theme you are tryig to use is broken or misconfigured?

PumWalters's picture

the thumbnails do appear OK in "Dashboard > Extend Concrete5 > Install" (where you download and install themes), but not in "Dashboard > Themes" (where you activate them).

I've tried lazy Days as well, which exhibits the same problem, although images do appear correctly in the home page (URL http://.../packages/theme_lazydays/themes/lazydays/images/bg/header_right.jpg).

In answer to your questions: Yes, I do login after install via ssh to finish installation, and I install themes exactly as you did.

One thing different from your setup is that my C5 serves from behind a LAMP web server proxy.

Wouldn't you know!. While working on this post, I tried another CMS (e107) but ran into a similar problem there. 

So I tried accessing these servers directly through DNAT on the Proxmox server, and lo & behold, the problems aren't there. Neither the faulty image-URLs, nor the PATH_INFO problem I met installing C5 on a fresh plain debian OVZ.

When I go through DNAT the application receives the right PATH INFO, whereas when I go there through Apache reverse proxy something is awry. Apparently my apache config is faulty.

For the moment: thanks for helping me. I'll get back if I know more.


Jeremy Davis's picture

I am not familiar with working behind a proxy, but my suspicion is that that is where your issue is creeping in. And I don't know for sure, but I further suspect that being behind the proxy is what is causing issues with your C5 install on vanilla Debian.

But TBH I don't know where to start with that... Sorry not much help am I!?

PumWalters's picture

Your answers do help me thinking in other directions, so I'm truly grateful.

PumWalters's picture

This turned out to be misconfiguration in my apache gateway/proxy. I've now starting using an nginx gateway, which is somewhat easier to configure. 

Fairly out of the box (the TKL nginx appliance) configured as follows:

upstream gateway  {
      server;   #internal lan IP of (in this case) Concrete5 appliance (LAMP)

server {

   listen      80;
   server_name yourdomain.com *.yourdomain.com; 
   location / {
        proxy_pass  http://gateway;
        proxy_redirect off;
        proxy_buffering off;
        proxy_set_header        Host            "yourdomain.com";
        proxy_set_header        X-Real-IP       $remote_addr;
        proxy_set_header        X-Forwarded-For $proxy_add_x_forwarded_for;

Then my proxmox ve delivers all external requests through DNAT to the nginx gateway


Jeremy Davis's picture

That's fantastic! Thanks.

Great to hear that you got to the bottom of your issues and even better that you posted back with a helpful post re Nginx config.

Great work! :)

Add new comment