BenL's picture

Hi, sorry if this is not the right place this.

Bug concerning web2py ISO appliance: CSS is not functioning correctly in admin page of web2py

Fix: in /etc/apache2/sites-enabled/web2py ..

change this line 

AliasMatch ^/([^/]+)/static/(.*) /var/www/web2py/applications/$1/static/$2

to

AliasMatch ^/([^/]+)/static/(?:_[\d]+.[\d]+.[\d]+/)?(.*) /var/www/web2py/applications/$1/static/$2

Solution in

https://groups.google.com/forum/#!topic/web2py/thSs622POoA

 

 

Forum: 
Tags: 
BenL's picture

Just another note when using this appliance: you might get an mysql error when following the tutorial 

http://web2py.com/books/default/chapter/29/03/overview#Startup

The error is 

1071, 'Specified key was too long; max key length is 767 bytes'

Culprit : 

db.define_table('image',
   Field('title',unique=True),   <-----
   Field('file', 'upload'),
   format = '%(title)s')

either use 
   Field('title',unique=True,length=255)

or 

db.image.title.requires = IS_NOT_IN_DB(db, db.image.title)

after the statement.

reference: https://groups.google.com/forum/#!msg/web2py/9AwEHOeLbds/5IzHL50LD2gJ

 


Jeremy Davis's picture

I have lodged it as a bug on the TKL Issue Tracker
BenL's picture

Hi Jeremy, Yes, the first post is a bug, but for the  mysql problem,  it is more of a mysql bug-feature than anything to do with TKL. It applies to anything running web2py-mysql not just TKL. Other database servers dont have this problem.  regards!


Tobias's picture

I have searched for a solution for a couple of hours until I found it. Was trying to get web2py running on RHEL with Apache. Worked fine on Ubuntu but a simple copy & paste wouldn't do it. I did check the scripts/setup-fedora.sh script and copied the Virtual Host configuration from there, still it was not working. Always was getting client denied by server configuration: /var/www/web2py/applications/$1 error. Now it works!

Add new comment