L. Arnold's picture
The posting is generated in: conf.d/main by the following line:
This posting seems to be hitting a part of the Database that is not there.  I am going to comment out this and the next few lines (very bottom of /conf.d/main ) so that I can at least see the data (if it is made).  I am a bit concerned that I have a few errors that went past reading:
"Class InstallationControllerSetup.saveconfig not found+ curl -c /tmp/cookie -b /.... (can't read from there)
(very bottom of /conf.d/main ) follows
# create welcome post
$MYSQL_BATCH --database=$DB_NAME --execute "INSERT INTO ${DB_PREFIX}content VALUES ('1', '35', 'Welcome to TurnKey Joomla', 'welcome', '', '<h2>Getting started</h2><p></p><ul><li>Log into the <a href=\"administrator\">administration console</a> as <strong>admin</strong></li> <li>Refer to the <a href=\"http://www.turnkeylinux.org/joomla32\">TurnKey Joomla release notes</a></li><li>Refer to the <a href=\"http://docs.joomla.org\">Joomla documentation</a></li></ul><p></p>', '', '1', '0', '0', '2', '2010-01-01 00:00:00', '42', '', '2010-01-01 00:00:00', '0', '0', '2010-01-01 00:00:00', '2010-01-01 00:00:00', '2020-01-01 00:00:00', '', '', '{\"show_title\":\"\",\"link_titles\":\"\",\"show_intro\":\"\",\"show_category\":\"\",\"link_category\":\"\",\"show_parent_category\":\"\",\"link_parent_category\":\"\",\"show_author\":\"\",\"link_author\":\"\",\"show_create_date\":\"\",\"show_modify_date\":\"\",\"show_publish_date\":\"\",\"show_item_navigation\":\"\",\"show_icons\":\"\",\"show_print_icon\":\"\",\"show_email_icon\":\"\",\"show_vote\":\"\",\"show_hits\":\"\",\"show_noauth\":\"\",\"alternative_readmore\":\"\",\"article_layout\":\"\"}', '1', '0', '1', '', '', '1', '0', '', '1', '*', '');"
L. Arnold's picture

(response was on separate Forum post, not Blog Post).

Code to instigate:

cd /turnkey/fab/products
git-clone https://github.com/l-arnold/joomla32 (should end w/ .git - problem #1)
cd joomla32

This is my error now that I commented out "#create welcome post" entries in conf.d/main

error is at the bottom of course

byte-compiling /usr/local/lib/python2.7/dist-packages/phpsh/html2text.py to html
byte-compiling /usr/local/lib/python2.7/dist-packages/phpsh/ init .py to  ini
byte-compiling /usr/local/lib/python2.7/dist-packages/phpsh/ctags.py to ctags.py
byte-compiling /usr/local/lib/python2.7/dist-packages/phpsh/phpsh.py to phpsh.py
byte-compiling /usr/local/lib/python2.7/dist-packages/phpsh/ansicolor.py to ansi
running install_scripts
copying build/scripts-2.7/dbgp-phpsh.py -> /usr/local/bin
copying build/scripts-2.7/phpsh -> /usr/local/bin
changing mode of /usr/local/bin/dbgp-phpsh.py to 755
changing mode of /usr/local/bin/phpsh to 755
running install_data
creating /etc/phpsh
copying src/rc.php -> /etc/phpsh
copying src/php_manual.db -> /etc/phpsh
copying src/config.sample -> /etc/phpsh
creating /usr/local/man/manl
copying src/doc/phpsh.l -> /usr/local/man/manl
running install_egg_info
Writing /usr/local/lib/python2.7/dist-packages/phpsh-l.3.egg-info
+ cd -
+ rm -rf /usr/local/src/phpsh
fab-chroot build/root.patched —script /turnkey/fab/common/conf/apache-vhost
fab-chroot build/root.patched —script /turnkey/fab/common/conf/postfix-local
[ ok ] Starting Postfix Mail Transport Agent: postfix.
[ ok ] Stopping Postfix Mail Transport Agent: postfix.
fab-chroot build/root.patched —script /turnkey/fab/common/conf/phpmyadmin
df: Warning: cannot read table of mounted file systems: No such file or director
[    ] Starting MySQL database server: mysqld ..............................
make:    [build/stamps/root .patched] Error 1

L. Arnold's picture

This is further up the Make Chain before final failure:

unable to connecto mysql server.

error encountered creating user:


non interactive fail

ignoring errors from here forwards:

dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf
Creating config file /etc/dbconfig-common/phpmyadmin.conf with new oersion
Creating config file /etc/phpmyadmin/config-db.php with new oersion
ERROR 2002 <HV000>: Can't connect to local MySQL server through socket '/uar/run
/mysqld/mysqld.sock' <2>.
unable to connect to mysql server.
error encountered creating user:
ERROR 2002 <H¥000>: Can't connect to local MySQL server through socket '/oar/run
/mysqld/mysqld.sock' <2>
dbconfig-common: phpmyadmin configure: non interactioe fail.
dbconfig-common: phpmyadmin configure: ignoring errors from here forwards
populating database via sql... done.
dbconfig-common: flushing administrative password
Setting up libdevmapperl.02.1:i386 <2:1.02.74-8) ...
Setting up libdevmapper-eventl.02.1:i386 <2:1.02.74-8) ...
Setting up libparted0debianl:i386 <2.3-12> ...
Setting up grub-common <1.99-27+deb7u2) ...
Setting up grub2-common <1.99-27+deb7u2) ...
Setting up grub-pc-bin <1.99-27+deb7u2) ...
Setting up grub-pc <1-99-27+deb7u2> ...
Creating config file /etc/default/grub with    new version
grub-probe:    error:    cannot    find    a    device    for    / <is /dev mounted?),
grub-probe:    error:    cannot    find    a    device    for    /boot <is /dev    mounted?),
grub-probe:    error:    cannot    find    a    device    for    /boot/grub <is    /dev mounted?)
Setting up di-live <0.9.4+5+g72866c5) ...
Setting up eject <2.1.5+debl+cvs20081104-13) ...
Setting up dmsetup <2:1.02.74-8) ...
Warning: Deferring update-initramfs -u
Setting up lvm2 <2.02.95-8) ...
Warning: Fake invoke-rc.d called
yarning: Deferring update-initramfs -u
Setting up casper <1.236-turnkey+12+gc47bd84)

L. Arnold's picture

Could someone can try Joomla25 build with TKLDEV.  It won't build for me as my own Joomla32 (based on Joomla25).  Same Error as above.

My Joomla32 gets that far if I comment out the "#create welcome post" in conf.d/main.

It fails before that otherwise so there is some variance in what is happening, but still not able to build.

Seems Like I have all dependencies into TKLDEV and I did run

apt-get update

then Restarted just to be sure.

any and all help is appreciated.

thank you,

L. Arnold's picture

Since No MYSQL would be included..  testing Posgresql (as I would use it for my next project anyway).  I am pretty sure I covered all the post install requirements in the TKLDEV build...  Must be an Issue there however. 

Variables that I can find reviewing the docs on Github.

I never built a Core App (trying now - just completed)

I never performed a Cleanup (trying next -  just completed on core - can't peform on failed folders)

I am using i386 Architecture

See POSTGRES Failure.

/scripts/casper-functions    f-'
/var/tmp/mkinitramfs_BKxUJ0/scripts/casper-bottom/25singleuser_shell:    6:    Can'S
t open /scripts/casper-functions
/var/tmp/mkinitramfs_BKxUJ0/scripts/casper-bottom/25ssh_emptypw: 6:    Can't    opeH
n /scripts/casper-functions
fab-chroot build/root.patched "rn -rf /boot/*.bak"
tt    ■
# tagging package management system with release package    I
# setting /etc/turnkey_version and apt user-agent
tt    ■
/usr/share/fab/make-release-deb.py /turnkey/fab/products/core/change log build/roH
Traceback <most recent call last):
File "/usr/share/fab/make-release-deb.py”, line 124, in <module>
File "/usr/share/fab/make-release-deb.py", line 121, in main
make_release_deb<path_changelog, path_output, depends)
File ”/usr/share/fab/make-release-deb.py", line 85, in make_release_deb
name, oersion, maintainer = parse_changelog<path_changelog)
File ”/usr/share/fab/make-release-deb.py”, line 64, in parse_changelog
firstline = f ile<path) .readlineO
IOError: [Errno 2] No such file or directory: '/turnkey/fab/products/core/changeH
log'    \
make: ***** [build/stamps/root .patched] Error 1    I—
rootPtkldeo    tt    M

 I am going to do a Snapshot restore to an "unrun" system.  Perform Apt-get update and give it one more try starting with Core, then going to Postgres, then to Joomla25 and Joomla 32 

This is a pretty big hit on Data throughput it seems.

L. Arnold's picture

I was missing the suffix ".git" on my git-clone commands.

That got Joomla25 to build.

Still had an error with my Joomla32 build though.  I need to burrow in to see how MySQL is built.

Error ended with:

running install_egg_info
Writing /usr/local/lib/python2.7/dist-packages/phpsh-l.3.egg-info
+ cd - |
/ Jp
+ rm -rf /usr/local/src/phpsh I
fab-chroot build/root.patched —script /turnkey/fab/common/conf/apache-vhost
fab-chroot build/root.patched —script /turnkey/fab/common/conf/postfix-local
[ ok ] Starting Postfix Mail Transport Agent: postfix.
[ ok ] Stopping Postfix Mail Transport Agent: postfix.
fab-chroot build/root.patched —script /turnkey/fab/common/conf/phpmyadmin
df: Warning: cannot read table of mounted file systems: No such file or directorl
y ;
[FAIL ] Starting MySQL database server: mysqld....................................... [.;
make: ****** [build/stamps/root .patched] Error 1

I tried to run Clean on a previous but because of the failure on it it won't clean.  
Joomla25 worked so somewhat at a loss.  I will see if I can find more about the phpmyadmin declration in Joomla25 and see why it doesn't work w/ Joomla32
Any thoughts out there on this?
Jeremy Davis's picture

I have found on occasion that if the build fails that you need to restart TKLDev then run clean (on reboot) to clear out the junk...

I think that if the build exits (i.e. errors) with MySQL running it can cause issues. I found simply restarting resolves this.

L. Arnold's picture

System is happy anyway.  I restarted the system first per Rik and Eric's forum thread recomendation


cd /turnkey/fab/products
git-clone https://github.com/l-arnold/joomla32.git
cd joomla32

Got to the end.  (commented out the Welcome Post section in conf.d/mail)

ISO Install test next :)

Jeremy Davis's picture

Awesome! Now fingers crossed for your ISO install test! :)

L. Arnold's picture

my joomla/configuration.php file is empty

my joomla database is empty

website returns:  "No configuration file found and no installation code available. Exiting..."

I suppose I will try to "uncomment" the "welcome post" section again in conf.d/mail.

Perhaps I was not getting beyond there because of the mysqld (aka restart neede) issue.

I am sorry I didn't see your note Jeremy about Restarting..  It looks pretty simultaneous.  We should update the docs on this.

Do you think the CLEAN also needs to be run before a New ISO is built or can multiple ISO's end up in a TKLDEV system without being CLEANED?  (OK,  see your note about also running clean)


cleaned and MAKE running now w/ comments REMOVED in conf.d/mail.

I think though there should be an install script in Joomla that needs to be called.  I have not yet found it.

L. Arnold's picture

The following thread has lots of "angles" on setting up Joomla Database version 3.0


I need to look a bit at how TKLDEV actually "does" mysql.  Seems like it is running (of sorts) but as I can't get into Webmin  don't know the details of shell/sql checks.

L. Arnold's picture

The Database tables don't seem to be created properly.  According to the above link, I should see if I can give more RAM and Longer timeouts to MYSQL for the build process (though who knows really)

ClasslnstallationControllerSetup.saveconfig not found* curl -c /tmp/cookie -b /
+ rn -rf /var/www/joomla/installation
+ mo /var/www/joomla/htaccess.txt /var/www/joomla/.htaccess
+ sed -i s r# RewriteBase /!RewriteBase /! /var/www/joomla/.btaccess
+ sed -i s!sef_rewrite = '0'!sef_rewrite = '1'! /var/www/joomla/configuration.ph
+ mysql —user=root —password= —batch —database=joomla —execute INSERT INTO
jos_content UALUES <'1', '35', 'Welcome to TurnKey Joomla', 'welcome', '', '<h2>
Getting started</h2Xp></pXulXli>Log into the <a href="administrator">administ
ration console</a> as <strong>admin</strongX/li> <li>Refer to the <a href="http
://www.turnkeylinux.org/joomla32">TurnKey Joomla release notes</aX/liXli>Refer
to the <a href="http://docs.joomla.org">Joomla documentation</a></liX/ulXp></
L>>', ", '1', '0', '0', '2', '2010-01-01 00:00:00', '42', ", '2010-01-01 00:00:
§0', '0', '0', '2010-01-01 00:00:00', '2010-01-01 00:00:00', '2020-01-01 00:00:0
0' , ", ", ' <"show_title":    "link_t    it    les": "", ,pshow_intro,p:,MP, "show_categoryu:"
", "link_category":,MP, "show_parent_category":,p,p, "link_parent_category":,MP, ,pshow_a
uthor":,plink_author,p:,p,p, ,pshow_create_date,p:,MP, ,pshow_modif y_date,p:,p,p, ,pshow_pub
lish_date":,p,p, ,pshow_item_navigat ion": "", "show_icons":"show_print_icon":"", "sh
ow_email_icon":,p,p, "show_vote,p:,p,p, "show_hits":,pshow_noauth,p:,palternat ive_re
&dmore"article_layout'1', '0', '1', ", ", '1', '0', ", '1', '*',
ERROR 1146 <42S02) at line 1: Table 'joomla.jos_content' doesn't exist
make: ***** [build/stamps/root .patched] Error 1
rootGtkldev    it

L. Arnold's picture

It was relatively quick to install manually after my iso.  Probably could make it quicker still.

I renamed /var/www/joomla folder to /var/www/joomla32 (to take it out of Apache)

I renamed joomla database (that was empty) to joomla-orig

I made a new folder /var/www/joomla

Inside the folder I ran in webshell:  wget http://joomlacode.org/gf/download/frsrelease/19239/158103/Joomla_3.2.3-S...

I then extracted the file inside the folder.

I gave all folders the standard TKL-Webserver user and group (755) folders, (644) files

Note:  There is no configuration.php initially

There is a /installation folder (that they require to be deleted after installation)

Going to the IpAddress/URL I was presented with the Joomla Installer.

the main thing was I installed

database:  joomla  (I defined tables to start with jos__

mysqli  (format - alternative avail is mysql)  I did not see InnoDB as a alternative in Joomla Install.  However, inside PhpMYSQL, the type of files are indeed InnoDB (I requested mysqli - so perhaps thesame thing ??)

jos_content is a table definition (among many others) in joomla database.

Very New Interface at first view of Admin, and nice on the standard Web Site.

Now to just get the install script working.  (detals below)

(more to follow, details below)



Joomla!® is free software released under the GNU General Public License.

    1 Configuration
    2 Database
    3 Overview

Previous Install
Install Sample Data

None (Required for basic native multilingual site creation)Blog English (GB) Sample DataBrochure English (GB) Sample DataDefault English (GB) Sample DataLearn Joomla English (GB) Sample DataTest English (GB) Sample Data

Installing sample data is strongly recommended for beginners.
This will install sample content that is included in the Joomla! installation package.
Email Configuration


Send configuration settings to admin@email.com by email after installation.
Include Passwords in Email


Warning! It is recommended to not send and store your passwords in emails.
Main Configuration
Site Name    Joomla32
Site Offline    No
Admin Email    admin@email.com
Admin Username    admin@email.com  (I should have said admin)
Admin Password    ***
Database Configuration
Database Type    mysqli  (phpmysql says INNODB)
Host Name    localhost
Username    root
Password    ***
Database Name    joomla
Table Prefix    jos_
Old Database Process    Remove
Pre-Installation Check
PHP Version >= 5.3.1    Yes  (I thought Wheezy was 5.4.4)
Magic Quotes GPC Off    Yes
Register Globals Off    Yes
Zlib Compression Support    Yes
XML Support    Yes
Database Support:
(mysql, mysqli, pdo)    Yes
MB Language is Default    Yes
MB String Overload Off    Yes
INI Parser Support    Yes
JSON Support    Yes
configuration.php Writeable    Yes
Recommended settings:

These settings are recommended for PHP in order to ensure full compatibility with Joomla.
However, Joomla! will still operate if your settings do not quite match the recommended configuration.
Directive    Recommended    Actual
Safe Mode    Off    Off
Display Errors    Off    Off
File Uploads    On    On
Magic Quotes Runtime    Off    Off
Output Buffering    Off    On
Session Auto Start    Off    Off
Native ZIP support    On    On
Joomla32 Appliance - Powered by TurnKey Linux  (THIS MADE IT IN SOMEHOW!)

L. Arnold's picture

It seems to me there could be some value to filling the fields in the Joomla Install Script rather than prefilling everything (which is failing).  Also it might give a nicer "landing" to new users.

I know, its not the way we do it..

Need to just work through the firstboot issue.  Somehow the Joomla Database was not at all populated w/ the pieces from the Joomla25 script.

Jeremy Davis's picture

But generally I think it's better practice to have it pre-installed and pre-configured with sensible defaults. Anything that needs to be configured should have an inithook. That way the values can be preseeded and there is no window of opportunity for the site to be hijacked or hacked (as installation is being finalised).

When I have got stuck with issues like your having I like to run through the commands manually to see what is going on (I have found that sometimes the errors that occur during 'make' don't give enough detail). If you use chroot (or IIRC you can use fab-chroot) then you can go into the root FS of you appliance build and see what is going on...

Add new comment