Erik's picture

Hi Support,


I've been pulling my hair out about this issue for a few weeks.


We have an older instalation of turnkey-redmine that has been doing backups daily to the amazon site.

We had a huge drive failure and have been trying to restore the data. However, during the restore, the following error presents itself and I can't get through it.  What did work, was doing a -skip filesystem, which gave us back the database.    

So redmine works, however, all the attachments that we uploaded to redmine have all gone missing.  I've attached the error of where it broke, and I'm hoping someone can give me a hand with restoring the files.


Another possible solution is to be able to download the raw data from amazon and open up the archives myself to go through it, if such a thing is even possible.

If you have any questions, I'll do my best to get the information you guys require.




Jeremy Davis's picture

Looking at your screenshot it appears to be a backup of a v11.x TurnKey build. Does that sound about right?

If so, are you restoring your appliance to a new shiny v13.0 appliance?

The following assumes that it is and you are...

My suspicion is that perhaps there is some sort of conflict between the old data (v11.x/Ubuntu 10.04 base) and the new appliance (v13.0/Debian Wheezy/7 base), although that is pure speculation...

A couple of things:
First it might be worth having a look in /var/log/tklbam to see if there is anything of particular interest in there (maybe some warning or something prior to it failing?).

Unfortunately I don't know that much about Redmine, but assuming that it stores attachments as files (in the filesystem as opposed to within the DB - as you said you've successfully restored the DB), then using the TKLBAM --limits switch to just download the folder where the files are stored might be worth a try... I would suggest that you also use the --skip-database and --skip-packages switches too.

Also the version of TKLBAM in v13.x is newer and adds some cool functionality that you might be able to take advantage of. One is the --raw-download switch. That will just dump all the data into a directory (of your choosing) where you can hunt through it and manually recover your files.

As a final resort (although probably unlikely to help you much) it could be worth trying a --simulate to see if that gives any errors.

Regardless, even if none of this works, at least we might get some more ideas of what is going wrong...

Erik's picture

Hi Jeremy, thanks for the reply.


Something I forgot to add, we're running Redmine virtually, and we have a snapshot of the VM that's a year old, and we've tried to restore it from that snapshot and it resulted in the same error.  (Which means it's trying to restore to the exact same version of turnkey/redmine)


My next job is to find out where Redmine stores it's attachments in the filesystem and see if I can restore that directory. If that fails, I'll try the --raw-download switch.



Erik's picture

Having done the --raw-download switch, I'm currently sitting at..



Last full backup date: Sat Mar 15 06:27:10 2014

Download s3:// failed (attempt #1, reason: BotoServerError: BotoServerError: 500 Internal Server Error
<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>InternalError</Code><Message>We encountered an internal error. Please try again.</Message><RequestId>82070AC74E91B47E</RequestId><HostId>wljC6GEqkF98cMdSJW3QIX9oGJgc3D0bWoyEgJdblYxOhOzWkts5QgXMH8mSR22+</HostId></Error>)



Erik's picture

Tried it again, it seemed to work this time.


however... According to turnkey, my last full backup was at the end of March, but I only have attachments as early as October 2013.  Still missing files.. and this is from the raw data too... Very very strange.  

Jeremy Davis's picture

Although only just...! If the files were there, then they should have been included in the full backup... Seems very odd that you don't have any attachment files since October...!

Unfortunately I don't have a clue what might be happening... I might understand it if it weren't successful in downloading the full backup, but not if it's saying it's successful. Is there a chance that something went wrong with this server prior to now (when you need the backup)?

Add new comment