Hi,

I have been trying to increase the max upload size without any success.  I have rwead several posts here and in other forums and tried all the recommendations.  It comes to this: whatever change I do to the php.ini files (there is no .htaccess in my installation) has no effect whatsoever: the max upload size is 2M.  Even setting upload off has no effect.  It looks that this is either hard coded or there is another configuration file that I am not aware of.

Thanks,

S

Forum: 
Jeremy Davis's picture

Have a look at the Fileserver specific docs. Or have you already tried that?

Yes, I tried adjusting the parameters indicated.  Just to remove any doubt I set file upload to Off  and everything remains the same.  I also rebooted the appliance between changes just to be sure.

UPDATE1: I was not aware of the lighttpd part (sorry, I am an embedded guy that does not know about php, ajax, and the like!).  In any case, I was never able to log in as admin into the Ajax explorer, I got the message: "illegal string offset 'disk'".  Also, I was looking into /etc/lighttpd/lighttpd.conf and there is no size-related parameter.  I need to continue looking for where that may be.

UPDATE2: I was looking for information regarding lighttpd and it seems the default is 2GB and it usually does not need to be modified.  As per the php.ini settings, this is what I tried (default in parenthesis):

  • file_uploads = On (I tried to set it to off and nothing changed)
  • upload_max_filesize = 50M (8M)
  • max_file_uploads = 20 (20)
  • max_input_time not defined (the default is -1: unlimited)
  • memory_limit = 250M (32M)
  • max_execution_time = 90 (30)
  • post_max_size = 200M (16M)

The virtual machine has 1GB RAM initial.  I had initially set up an extended volume for increased capacity.  I am now trying the pure vanilla installation.  Same results: upload fixed at 2M.

I would appreciate some help on this.

Thanks,

Shiryu

Mumbling:

Apparently, all the problem was that not being able to log in as the Ajaxplorer admin and making the needed changes in the upload plugin setting caused that the changes I had made in the php.ini file were overwritten.

Fact:

The reason why I could not log as admin was that I was trying to log into the Samba domain, not in Local (an option you can pick from the inconspicuous pull down list in the login window!!!).  Oh, the disadvantages of not knowing what one is doing! :)

 

Hope this will help others to avoid this pitfall.

Peace,

 

Shiryu
Jeremy Davis's picture

Glad you got it sorted and thanks so much for posting back!

Perhaps that little gem needs to go into the docs!? It's probably one of those things that to those that know, it seems intuitive; but to those that don't, it doesn't even occur to them...

Add new comment