Olivia's picture

Hi everyone,

I have just made my first domain on a Linux Debian TurnKey machine, and everything works fine. Though, I do have a question.

I have a storage folder on a NAS box (Storage device) and I want to share that folder to my domain users via Turnkey. Is there a way to mount that share to my Turnkey? And if there is, how can this be done?

I use a Buffalo LinkStation Nas, where I have also tried to connect it with the domain option, but this is not possible - But it works fine on clients and other host machines.

And just all in all, how I can mount an existing share to Turnkey?

Many thanks in advance! 
Kind Regards,

Jeremy Davis's picture

You'll need to look at mounting that on your TurnKey server, and mount it to a place that is accessible. TurnKey is build on Debian stable, so I'd have a google about mounting SMB shares under Debian Wheezy.

Let me know if you encounter any issues.

Olivia's picture

Thank you very much for the quick reply! :-) I found some usefull sites for mounting a share, but my trouble is that my NAS box can't sign in to the domain and this is why I am a bit unsure what address I can use to mount them.

Like, my NAS box has the ip address of and a share called 'Share' but will only open the NAS.

Jeremy Davis's picture

Your TKL domain box will need to 'sign-in' to your NAS. You'll then need to mount the NAS share on your TKL box. Then 'reshare' it from there (to your domain). You should find adequate info online (probably google something like "mount samba share debian server"). FWIW a couple of links that jumped out at me were this one and this one but you should find plenty of info...

It may take some tinkering to get the permissions right (so the read/write access works as it should), but in essence it should be fairly straight forward.

Olivia's picture

Hi Jeremy,

Thank you for a great anwser once again. I have managed to mount the NAS storage to my Turnkey, and it all worked perfectly. And that was actually all I needed.
My one concern was, that when I tried to join the Buffalo NAS box (it has a join NT domain function) it didn't work with the correct credentials, which worked on host machines etc. The NAS is new and firmware upgraded. Anyway, I figured that if you use the Workgroup function and delegate the authorisation to a SMB server (which is a checkmark you can check under Workgroup) it worked perfectly fine.
Now it can only be open, if the SMB server gives you access. You can't open storages directly or from other ways, than just signing into the domain and receive access.

So it worked perfectly! Thank you for your advices, all I needed was to mount the share :-)

Jeremy Davis's picture

Glad to be of assistance Olivia!

And cool that it works as you had hoped. That Workgroup function (to delegate authorisation to a SMB server) sounds very handy.

Have fun. :)

Olivia's picture

Indeed it is :-) And thank you for your help!

Add new comment