Laurent LANDREAU's picture


I am using the following Turnkey AWS AMI:

turnkey-mysql-13.0-wheezy-amd64.ebs_2-7fe45e5a-7d7e-4fa9-b12b-fd5646104273-ami-275b094e.2 (ami-0b3ea231)


The instance (i-cabe76f4) is created normally, it is accessible via the web, or ssh. Note that the security group associated with the instance contains the correct MYSQL ports and is accessible by all IP@ (

1) When I try accessing it (http or ssh) using the default 'ec2-user', it mentions that my AWS keys are not recognized and it prompts me for a password ... that of course I do not know.

2) I have accessed the Amazon system log, retrieved the 'root' generated password and tried connecting via Putty/SSH but then the window appears and goes off.


Am I missing something in that instance?



AWS Architect, Brisbane, Australia


Laurent LANDREAU's picture

Addition to the previous message:

- when connecting with 'ec2-user', error message is: server refused our key.

- when connecting with 'root' and the password found in log, the message Authenticating with public key "imported-openssh-key" .... and then disappears without providing the login prompt.


Thanks, Laurent

Jeremy Davis's picture

I.e. connection as root user using the password from the log should do it...

If you have keys set up in your Amazon account though I was of the understanding that so long as you have the keys set up on your end too (i.e. in your SSH client), that you could log in via SSH without a password (although still using root). But TBH I haven't used TurnKey on AWS except via the Hub.

You must have been posting same time as me! :)

Thanks for extra info. I'm not sure why that's not working, but perhaps try logging in with the password (not the key). I still think that it should have worked...

Laurent LANDREAU's picture

Using putty:

- removed the SSL key.

- tried to connect with 'root', got the password prompt, ... but when I enter it (obtained from the System Log), the putty windows disappears.


Tried through the web via port 13320 ... and it worked ... although not all characters where visible. 

But it is done, problem solved.





Jeremy Davis's picture

Glad you got there in the end. Still it seems strange...

Add new comment