Landis Arnold's picture

So, I just migrated via TKLBAM to a Magento Hub Install.  Historically a TKLBAM move would move my SSL Certs (and in fact the files did move).  However the default did not take so I went to build one from scratch the way I am accostomed.

Generated a new CSR

Reissued a new CRT having submitted the new CSR (namecheap.com)

Recieved a CRT and a INTCA CRT

Dropped them in a new folder parallel to my old folder /etc/ssl/newfolder

Edited my Configuration in Apache.

But then I get the error  like the following

SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

The structure of the CERT certainly follows the pattern of my last CERT which was in a VMWare Image 32 bit build (this is 64Bit Hub new Machine from Backup to Hub)

This Discussion (or series of shotgun blasts) has a series of possible answers but not Turnkey specific:  http://stackoverflow.com/questions/119336/ssl-error-rx-record-too-long-a...

Thoughts?

thanks in advance.

Forum: 
Jeremy Davis's picture

I'd try checking (in this order):

  • Make sure you do not have more than one SSL certificate sharing the same IP. Please ensure that all SSL certificates utilise their own dedicated IP.
  • If using Apache2 [which TurnKey does] check your vhost config. Some users have reported changing to _default_ resolved the error.

To check your vhost config see what site(s) is/are enabled (IIRC by default it should be 'magento' only):

ls /etc/apache2/sites-enabled

Then view the actual 'site' info by browsing to the file in /etc/apache2/sites-available. E.g. assuming it is 'magento' then:

cat /etc/apache2/sites-available/magento

If you want to try adjusting I suggest you copy it first (with command 'cp') then edit with 'nano'.

My suspicion is that it is the first one (i.e. whilst something went wrong with the SSL migration, it is still registered somewhere, then when you added another), but who knows? maybe worth trying the second too?

Landis Arnold's picture

Whether I restore to Virginia or Oregon in the Hub from my VmWARE inhouse system, Magento is giving the root directory to be

var/www

rather than

var/www/magento

I have tried on 3 systems now and always the same result.  I can get different Domans to find the www. directory but I can't get any of them to find the magento directory without explicitly opening it (as it is given as a directory).  Problem is that Magento is using rewrites and does not want that folder structure in its links.

I don't have a problem with VmWare restores (though I have not tried one recently).

I've been trying to jump over to Amazon but this is blocking the whole move.

Any Thoughts?  I am sure the SSL issues above are related to the Host files.  Basically I can't seem to get response to Hosts in Amazon (and I get the wrong directory to boot)

 

Jeremy Davis's picture

Sorry for such slow response...

Hey Landis, how are things going with this? Sorry I haven't replied sooner but I've been flat out...

That seems really weird. Are you using the default TKLBAM profile or have you tweaked it? I'm sure that it shouldn't be doing that!

The first thing I'd check is that for some reason the Magento Apache 'site' hasn't been disabled. Have a look in /etc/apache2/sites-enabled and see what's there. If it returns anything other than 'magento' and 'phpmyadmin' then I reckon that's your problem.

Apache 'sites' can be enabled or disabled with the a2ensite and a2dissite commands (respectively). I.e. to disable default and enable magento:

a2dissite default && a2ensite magento && service apache2 reload

Hope that healps. If you're still stuck please post back and I'll try to reply a bit quicker this time...

Add new comment