waspinator's picture


I have a Windows 2012 domain set up with an ldap server running on it. I also installed a gitlab turnkey linux server. (used just the core turnkey linux image and then installed gitlab manually since the appliance version was out of date)

For users to be able to use git, they need ssh keys and ssh access. I have gitlab set up with ldap so users just use their regular windows username and password to log into the web interface, and I'd like for them to do the same for ssh.

How can I set up turnkey / webmin to auto authorize / add users from the LDAP server?


waspinator's picture

I installed the following packages

libnet-ldap-perl libpam-ldapd libnss-ldapd ldap-utils webmin-ldap-client

and changed the ldap configuration file location from /etc/ldap.conf to /etc/ldap/ldap.conf

This allowed to me to configure turnkey/webmin to access my ldap server and browse my ldap users.

I'm still not able to validate my settings though, as I'm getting the following error:

Finding LDAP base for users ..
.. found base OU=LdapUsers,DC=lan,DC=mydomain,DC=com.

Connecting to LDAP server ..
.. connected to ldapserver.lan.mydomain.com

Searching for users ..
.. no users found under base OU=LdapUsers,DC=lan,DC=mydomain,DC=com.

but using the LDAP Browser I am able to see all the users by browsing to


I added UNIX attributes to the Windows 2012 server using the following procedure:

In an elevated PowerShell console I ran these commands:

Dism.exe /online /enable-feature /featurename:adminui /all
Dism.exe /online /enable-feature /featurename:nis /all
Dism.exe /online /enable-feature /featurename:psync /all

I then rebooted the computer and added a new security user group in windows Active Directory Users and Computers named 'unixusers'. I changed the UNIX attributes of the 'unixusers' to use the 'lan' NIS domain, and left the GID at 10000.

I then edited a user's UNIX attributes and set it to use the 'lan' NIS domain, leaving the other options default. I then added that user to the 'unixusers' groups UNIX attributes 'Members' section.

still not finding any users...







Add new comment