Kit's picture


So I had a Small Nginx PHP FastCGI appliance launched.

Everything was running pretty and I was developing on it without any issues.

Then yesterday, during a ssh session into the server, I ran:


shutdown -H -p now

Not sure why I ran it, maybe a force of habit, but I must have just thought I can start the server later.

Turns out the status shows up now as "Destroyed"

Maybe I'm missing something, (hopefully I am)

Please help me get my server booted again or back up.

Spin up an appliance, and issue the shutdown command after you ssh into it.

See Image.

Any help is greatly apprecaiated and thanks in advanced.




Liraz Siri's picture

Hi KIT, hopefully you have a TKLBAM backup for that server. S3 backed instances are ephemeral/transient. That means if you shut them down you lose the local storage. I know you probably didn't realize the difference between S3 backed instances and EBS backed instances. It's why the Hub defaults to EBS backed instances nowadays. If you shutdown an S3 backed instance from the Hub it warns you about this and suggests you backup first.

Another advantage is that EBS backed instances can be snapshotted for backup purposes. It's a nice feature that can get you back up and running even faster than restoring from TKLBAM.

Kit's picture

Liraz -


Everything you said makes sense.   Always good to learn from mistakes.

Having someone explain what happened and why.  Even better!  

This is valuable information.

Also, yes! TKLBAM indeed saved the day. 

I was able to restore a week ago backup and restore the differences I had locally.




Add new comment