unmet dependencies:

Bigfoot53's picture

Hello Everyone,

I am trying to update and install memcache on my zurmo VM. I can run apt-get update and it works fine then i try install-security-updates and ui get the following erorr.

+ SEC_UPDATES=FORCE
+ /usr/lib/inithooks/firstboot.d/95secupdates

Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
Reading package lists...
Building dependency tree...
Reading state information...

E: You might want to run 'apt-get -f install' to correct these.

The following packages have unmet dependencies:
openssh-server : Depends: openssh-client (= 1:6.0p1-4) but 1:6.0p1-4+deb7u2 is installed

Unmet dependencies. Try using -f.

I tried the apt-get -f install but get the same error. How can I fix this issue ??

Thanks
Bruce

Jeremy Davis's picture

I just checked a TurnKey v13.0 server (FWIW it was Moodle, but it shouldn't really matter) and both openssh-server and openssh-client are at version 1:6.0p1-4+deb7u2!

What do you get from the following?:

apt-cache policy openssh-server

Hope you don't mind I edited your post to make it a little easier on the eye! :)

bigfoot53's picture

Hello Jeremy,

Thanks for the reply,

Below are the results.

openssh-server:
Installed: 1:6.0p1-4
Candidate: 1:6.0p1-4+deb7u2
Version table:

1:6.0p1-4+deb7u2 0

1:6.0p1-4+deb7u1 0

*** 1:6.0p1-4 0

100 /var/lib/dpkg/status
Jeremy Davis's picture

IMO apt should just take care of it (and update OpenSSH server if it needs to). But obviously it's not for some reason...

FWIW did you try fixing it with the following? That will often work...

apt-get install -f

I guess if that doesn't do it you could also try just manually update OpenSSH...

apt-get update && apt-get install openssh-client openssh-server

FYI the deb7u2 packages come from the main repo (not security - the deb7u1 package comes from security) so at some point you must have manually updated one of them... Not that that explains why it's not working now...

bigfoot53's picture

Results
bigfoot53's picture

Jeremy Davis's picture

And TBH I'm starting to run out of ideas. Is this a new (or newish) install or has it been around a while? Where abouts is it running? Is it on bare metal? A VM on a local machine? A VPS in the cloud?

Your screenshot is a bit hard to read so I'm not totally sure whether it is likely to be corruption, but perhaps try is to clean the apt cache and try again (in case the deb is corrupt).

apt-get clean && apt-get update && apt-get install -f

And/or

apt-get clean && apt-get update && apt-get install openssh-client openshh-server

Or if that doesn't work, then try manually installing OpenSSH client

dpkg -i /var/apt/cache/openssh-client*.deb

And repeat for OpenSSH server. Then keep your fingers crossed and hope that it works this time. Otherwise personally I'd be concerned about what else might be broken on your server and why... File corruption? Hardware on it's way out? Malicious attack? Misconfiguration caused by someone who doesn't know what they're doing mucking with your server? I don't mean to alarm you and TBH I have no idea. I'm only throwing ideas around, but if you haven't been fiddling with it and this has just occurred on it's own, I would be a little concerned and would probably be making sure that you have a recent backup (that you have tested) and perhaps even try deploying it on a fresh TKL machine (even if just a local VM) and see if that has the same issues.

bigfoot53's picture

Jeremy Davis's picture

From my research it seem likely that your issue is caused by the debconf package becoming corrupt. This leads me to 2 things:

Firstly, (assuming my research was right) you should be able to fix it by downloading and reinstalling debconf. Then fix your other packages... So try this:

wget http://ftp.us.debian.org/debian/pool/main/d/debconf/debconf_1.5.49_all.deb
dpkg -i debconf_1.5.49_all.deb

Then try this again:

apt-get install -f

The second thing though, is why this happened in the first place... Personally I'd make sure that you have regular backups enabled (both for this VM and for the host's storage) and I'd encourage you to store a set of backups on some external storage (either a removable storage medium or another computer - i.e. not the host PC's HDD).

bigfoot53's picture

That worked!!

I ran the commands and it Corrected the errors. I was then able to install Memcache on the system.

THanks for all the awesome help :)

I have regular backups scheduled nightly to 2 different sources so i should be covered in that area.

I am not sure how the debconfig package could have gotten corrupted the only updating i have done on the system are the Zurmo upgrade releases that they post from time to time. I wouldnt think that would affect the main linux system?

 

Again thank You for all the help.

 

Bruce

 

Jeremy Davis's picture

I'm so glad to hear that we got you going again! :)

Seeing as you have backups sorted, I'd probably do a disk check on the host system just in case there is some minor corruption on the HDD.

Neil 's picture

I was having the same issues and reinstalling debconf fixed it. Thanks

Post new comment