Terry Urnkey's picture

I want to use a template to use this intresting fileserver

i have been using openvz through the last few years really like how I can separate a wasted cpu server into something running many things.  now I see the images

I am able to login but it does not seem to let me create users "User already exists, please choose another login!" I tried every random name filled in as much as I can so many times clearly I am missing something.

Google seems to have a few pages linked from these forums that fix different bugs but not alot of info. so heck maybe I just need to update it..

things like upgrading it "Please check that the application folder is writeable before launching upgrade." and it gives a error i would love to give this mystery application folder the rights it deservers to get the upgrade. but I am hard up to google or find where it is hiding!

"Applying upgrade ajaxplorer-core-upgrade-4.2.3-5.0.0.zip Checking download permissions - OK Downloading upgrade archive - File saved in /var/www/ajaxplorer/data/tmp/update/ajaxplorer-core-upgrade-4.2.3-5.0.0.zip Checking archive integrity - Hash is ok (ccb9c6c3c910d8c84ac34eb5d8d6d92b) Checking folders permissions - Error : The root install path is not writeable, no file will be copied! The archive is available on your server, you can copy its manually to override the current installation."

 

Do i throw it away? someone must know these answers and know exactly what to do or heck a hint that will allow me to document it!

Forum: 
Jeremy Davis's picture

I personally use the OVZ templates a lot, for both my personal testing and production (personal and professional). I use them on ProxmoxVE (open-source Debian based hypervisor which supports both OVZ and KVM) though rather than on vanilla OVZ. I recall that initially there were some issues running the first official TKL OVZ release on vanilla OVZ but that was a long time ago now and AFAIK they have all been resolved.

The patch you link to was my initial efforts to port TurnKey to run as an OVZ container. It was a TKLPatch which converted an appliance ISO to an OpenVZ template.

So short answer is that the templates that you link to on SourceForge should all just work!

Terry Urnkey's picture

ahh I got it running and then found some more road blocks so i edited my post .. for thous reading this above and wounder i was asking if I need to apply some patches.   Thank you for your quick responce.

I have it humming along but it seems it needs some tweeaks to get it operational.

if I could add users  or figure why it will not let me add users.

It looks super simple in youtube videos and that i might have a bug

is there a fix.

note I edit the post above and posted  the errors I have and will give any info  anyone needs to help me lick this issue. really want to try this out!

Terry Urnkey's picture

ok got the upgrade to work.. ssh in to the root@yourip
then

cd /var/www

chmod -R  777 *

everything just started working now.. the literary term "application folder" seems to mean /var/www
I was logged in using samba under the default admin (no password)
it kicked me out

now it shows pydio at the web interface

I tried to login with the admin but I just get "explode(): Empty delimiter" error in red at the bottom then it disapears.   alot happened in that update so maybe I give it a bit to do what ever it does in the background.. the dropdown that I am guessing would have samba or local  seems empty.  maybe it needs a reboot.

 

 

Jeremy Davis's picture

But as I said, I use it on Proxmox and they were designed to be fairly tightly integrated into Proxmox from the get-go. AFAIK Proxmox uses a fairly recent RHEL6 (2.6.32) kernel (rebuilt to work with Debian).

When you first create your container from the template you will need to complete the 'first-boot' init scripts. They should auto start when you log in (as root: using the password you set when you launch the container). That will guide you through what needs to be done to get started. If for some reason they don't autostart (or you want to re-run them) you can do that with the 'turnkey-init' command.

Once that has been done it should just work...

Out of interest, what did you need to tweak to get it to work?

terry's picture

I logged into tthe web interface  was unable to login with the local setting using just admin no password, but it worked with samba and admin no password.
aftter adding a few things and attempting to add users (see above) i eventually tried to ssh in . and I did the basics. but still was unable to create users. i will give it anouther run tommorow.

tweak

I was refering to I might not have the right rights to files or missing some things or need to patch some bugs . Because out of the box on my Debian 7 openvz 2.6.32-openvz-042stab093.5-amd64

using

wget http://sourceforge.net/projects/turnkeylinux/files/openvz/debian-7-turnk...

vzctl create 101 --ostemplate debian-7-turnkey-fileserver_13.0-1_amd64 --config basic
vzctl set 101 --onboot yes --save
vzctl set 101 --hostname ftp.domain.com --save
vzctl set 101 --ipadd 192.168.1.101 --save
vzctl set 101 --diskspace 900G:950G --save
vzctl set 101 --capability sys_time:on --save
vzctl start 101
vzctl exec 101 passwd

seems to not let me make any users

When I did figure how to update it (see above) I was no longer able to login.

Looks like there was alot of updates since then. Might of broke a few things.

 

Jeremy Davis's picture

Proxmox has a fantastic WebUI so I don't remember the last time I launched via commandline. It also allows setting of root password at launch too. I just launched a fresh instance in PVE in the hope that the interface would tell me the command it used - earlier versions used to, but it seems not anymore... FWIW here is the conf file for the new container:

ONBOOT="no"

PHYSPAGES="0:1024M"
SWAPPAGES="0:1024M"
KMEMSIZE="465M:512M"
DCACHESIZE="232M:256M"
LOCKEDPAGES="512M"
PRIVVMPAGES="unlimited"
SHMPAGES="unlimited"
NUMPROC="unlimited"
VMGUARPAGES="0:unlimited"
OOMGUARPAGES="0:unlimited"
NUMTCPSOCK="unlimited"
NUMFLOCK="unlimited"
NUMPTY="unlimited"
NUMSIGINFO="unlimited"
TCPSNDBUF="unlimited"
TCPRCVBUF="unlimited"
OTHERSOCKBUF="unlimited"
DGRAMRCVBUF="unlimited"
NUMOTHERSOCK="unlimited"
NUMFILE="unlimited"
NUMIPTENT="unlimited"

# Disk quota parameters (in form of softlimit:hardlimit)
DISKSPACE="4G:4613734"
DISKINODES="800000:880000"
QUOTATIME="0"
QUOTAUGIDLIMIT="0"

# CPU fair scheduler parameter
CPUUNITS="1000"
CPUS="1"
HOSTNAME="tkl-files.home.local"
SEARCHDOMAIN="home.local"
NAMESERVER="192.168.1.1 8.8.8.8"
IP_ADDRESS="192.168.1.123"
VE_ROOT="/var/lib/vz/root/$VEID"
VE_PRIVATE="/var/lib/vz/private/123"
OSTEMPLATE="debian-7-turnkey-fileserver_13.0-1_amd64.tar.gz"

I'm sure that the root password is set via vzctl though. Once the container is created the first thing to do is start it (obviously). Then it will auto install all security updates from Debian repos. After that is finished then you need to run the inithooks as I mentioned. Once that is done then you are ready to go (either quit out of the Confconsole back to commandline, or just shut session).

TBH if I were you, I'd probably be inclined to start again... You should not need to do any tweaks or adjustments. If you do then there is something wrong with your setup... Make sure you wait for all the updates to install, then run through the inithooks before you do anything else...

TBH I'm not 100% clear on what you are referring to when you say the "web interface". Are you referring to Webmin (https via port 12321)? If so, you need to log in as 'root' (using the root password you set with vzctl i.e. the Linux root user credentials). If you mean Ajaxplorer (https/port 443) then that is 'admin' using the password you set with the inithook (from the commandline).

Once you have all that done, then you can create your new Linux users. You can use commandline or Webmin. Note: if you want the user to have access to the default share (/srv/storage) then add them to the 'sambashare' group. I just tested this via commandline:

adduser test
adduser test sambashare
smbpasswd -a test

If you use Webmin then you'll need to create the user and add the sambashare group (under System>>Users and Groups>>Create a new user) then add the Linux user as a Samba user (under Server>>Samba Windows File Sharing>>Convert Users).

Once I did that (the commandline version) I logged into the Ajaxplorer interface using the username 'test' and the password I set following the 'smbpasswd' command above.

Note that if you want to use other file transfer methods (e.g. FTP) with these same user accounts then you'll need to do further config (with the exception of root). SFTP (FTP over SSH) is installed by default but you'll need to add your users to the 'ssh' group if you want them to also use it. Also note that SFTP chroot jails are a bit tricky to implement and by default all SFTP users will have full read access to the whole filesystem. If you want a secure FTP with users being locked to their home dir (ie.e chroot jail) then I would suggest configuring FTPS (FTP over SSL/TLS) with a package such as ProFTPd or vsftpd.

Add new comment