nginx-php-fastcgi not displaying PHP syntax errors

Guillermo's picture

I have launched an Amazon EC2 instance using http://www.turnkeylinux.org/nginx-php-fastcgi which worked great.

However my server is not displaying PHP syntax errors which makes it very tedious to troubleshoot. The only thing I get when my syntax is wrong is a blank page.

No matter what changes I make to the /etc/php5/cgi/php.ini file they don’t seem to have any effect...

This is probably stupid simple, but I just can’t figure it out and its driving me crazy... Any ideas?

Guillermo's picture

By the way, this is my PHP info http://wellmadestocks.com/webpanel/phpinfo.php

I am aware that "display errors" is set to "off", but like I say, no matter how much I modify the /etc/php5/cgi/php.ini file that doesent change...

I look forward to anyone's comments.

Thanks!

Jeremy Davis's picture

But the quick bit of googling I did suggests that getting in-browser error messages may not be possible... So the workaround options as I see them are:

Do your development in a traditional Apache environment then move to Nginx env for production.

Or use the Nginx error logs for your troubleshooting (not sure on filename but should be in /var/log).

Don't take this as a definitive answer; just the best I could manage with the time that I spent researching (and being totally unfamiliar with Nginx and how it interacts with PHP-FastCGI)).

You might have more luck with research yourself though? If you keep in mind that TurnKey v13 is based on Debian Wheezy and all software for this appliance comes from the Debian repos (with some custom config as per the appliance build code). If you do find how to do what you are after it would be great if you could post back.

Post new comment