J0hnTK's picture

Hello, I am new with turnkey, and just installed it as a guest on esxi 5.5

I cannot seem to figure out how to:


Create users

Create new folders/create directories

Upload files, error message states file size is too big.


Would anyone be able to assist with how to's? I also did not find anything for this in the forum when I searched, but I wouldn't be surprised if this has already been asked.



Jeremy Davis's picture

There are over 100 different appliances that include many different types of software. So it's hard to give any meaningful advice without knowing a little more... If you can name the appliance and then explain a little about what you are trying to do.

FWIW One sure fire way to upload files is via SFTP. You can use software like Filezilla...

J0hnTK's picture

**** I am being flagged for posting screen shots, so ill post just the words.



Thank you for letting me know I need to provided some clarification

Linux fileserver 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64
Welcome to Fileserver, TurnKey Linux 13.0 / Debian 7.2 Wheezy

AjaXplorer version 4.2.3

Two remaining issues,

1. In the picture below shows file limit size of 2 M. I found logging into the Webmin on port 12321, I found a previous support question state file size can be changed under File Manager /etc/php5/cgi and the php.ini file
In the editing tool, I have changed this to 304M (assuming its megabytes)


But as you can see the previouc pic shows the limit is 2M.

Below is the edit file I changed:

Can you assist with changing the upload file size?


I plan on using this to back up files, large iso's, ova's, excel files, etc. Also I plan on creating accounts for family members to save stuff to the "cloud" for them. So asking some familiy members to use filezilla is probaly beyond their skill level, I was hoping a nice web page login and gui would be easier for them.

2. Where would I create users, and creating different users like an admin account for me, and non admin for family members?


BTW, It seems logging in as 'root' and with a password allows me to create directories, when I logged in as 'root' and no password, it failed to create directories.

J0hnTK's picture





J0hnTK's picture

; File Uploads ;

; Whether to allow HTTP file uploads.
; http://php.net/file-uploads
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
; http://php.net/upload-tmp-dir
;upload_tmp_dir =

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 5000M

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 20




These are my current settings, but i am still seeing a 2M size upload limit

Jeremy Davis's picture

IIRC the new settings don't apply until Apache is restarted. Try:
service apache2 restart

Add new comment