L. Arnold's picture

Running TKLDEV

just brought in tkl-setup

then apt-get upate

Got the following error:

There is no Public Key available for the following public Key ID's

(long ones)

 

///////

 

But MAKE on basic Core

and 

MAKE on LAPP (renamed ODOO-LAPP)  (new build)

failing with Error

Unable to locate package isolinux

(on any build)

Unfortunately I killed my functioning TKLDEV image an hour ago so can't go back to that one.  Maybe I have a real old one..  Joomla32..  will try next.

Forum: 
L. Arnold's picture

I see in the Docs that the old Source was Sourceforge.

Perhaps all sources are not loaded into Mirror yet??

Likely all there but.. ?

L. Arnold's picture

MAKE worked on 386 Ver of TKLDEV.

I did not run updates, and it seems Make is making its way through a Cloned Lapp.

Failed prior to Apt-Get Update.

UNABLE to finds some Archives...  

Host pi.turnkeylinux.org lookup failed: Timeout

recomends:  maybe run apt-get update or try with --fix missing.

(I did run apt-get update on Wheezy64 System but failed)

Will try on this after Snapshot .now 

 

_iWondering if the tkldev-setup is out of synch somehow with the Wheezy OVF I downloaded a few weeks back..

Likely should do a new Pull of TKLDEV for 64 Wheezy and use ISO just in Case.

Jeremy Davis's picture

Because over the last week Alon has been updating stuff for the upcoming v14.0 release. So if this is a new set up you'll need to either wait for the v14.0RC1 release (which will be really soon) or you'll need to make sure that you don't download the latest common, bootsrap etc... You should be able to use the github tags (i.e. v13.0)
L. Arnold's picture

I've downloaded and installed Jessie RC1 and am testing on Core right now.  Always takes a while but seems to be working.  (WORKED!)

Main thing to note is that TKLDev-Setup needs to be run, but it does not need to be downloaded.  Not really clear why it does not run automatically, but good for me to figure that out anyway.

TklDev-Setup basically clones Core as far as I can see in the Jessie build and does not do too much else.

Since there is a Core RC1 also, this is just an exercize.  Will see what happens on Lapp etc next.

Never a short process.  No errors yet though ! (You guys are pretty amazing if you ask me!)  Where do the ISO Images land?  (added the answer inset)

cd core
make

The build should take about 3-5 minutes.  (15?)

The above will create build/product.iso which you can image to a USB drive, burn on a CD or copy to your host system for testing in a VM.

I hope that Wheezy, Squeeze etc will still work if folks are processing with them.  As noted my Wheezy 386 TKLDEV (from ISO) worked yesterday but not a new Wheezy 64 OVF version of TKLDEV  (perhaps If I run again, I can skip the download and TklDev-Setup is ready to run in Wheezy as well.  Trick is to see if it is there in /usr/local/sbin  as it was in Jessie version)

Expect I need to get my arms around SSH Keys soon.  Separate Thread.

L. Arnold's picture

seemed close but we got to here:

touch:  cannot touch '/etc/apache2/conf.d/phppgadmin' No such file or directory

/usr/share/fab/product.mk:476  : recipe for target 'build/stamps/root.patched' failed

Error 1

Likely Lapp has not caught up with Core with different build schemes.

back to the project w/ 386 Wheezy.  Cool to see Jessie running though!

(Support not needed just now as this is Off the Current System)

L. Arnold's picture

As Jessie is forcing a change to either the file name or the Folder structure, seems the Lapp.mk (or something) file needs to make the file go one way above Jessie, and another way below Jessie.

Testing some Odoo builds.  Running into the same w/ Jessie.

386 Wheezy TKLDEV working at it now.  Looks like some of my packages are coming in now..  cool.

Will report more.

 

Jeremy Davis's picture

I hope to get ALon to merge them in the main TKL repo really soon (within 24 hrs).
willem's picture

This is what I did to get back to a version before the isolinux-related changes:

# cd /turnkey/fab/common
# git checkout c5107c75eb5f26a5237393d0f0428b9c719d2be7
# cd /turnkey/fab/products/tkldev
# git checkout 2359d0e3d31425388d9d312702e90b696c887c61

At least it's finding all packages now, waiting now to see if the full build-process succeeds.

willem's picture

When building a new TKLDev image after this, it works (though still based on Debian "wheezy"). Somehow the graphics isolinux image on bootup is missing, just type install on the isolinux prompt (or use tab to see which commands are available).

Jeremy Davis's picture

And I reckon that we'll tag the older wheezy stuff v13.1 (even though technically there is no v13.1).

Out of interest is there a specific reason why you're not keen to be working on Jessie/v14.0? Or was it just because that wasn't working properly?

L. Arnold's picture

Fundamentally the SSL issues I was running into in Jessie wanted me to see if my builds (focused on SSL changes) were working at least in Wheezy.

It seems you posted something about SSL changes in Magento that might model the SSL changes needed in general for Jessie.

I do think it is important that the different rungs of the ladder work and work into the future.  It seemed that the Wheezy package was pulled forward in such a way that the general (on site last week) TKLDEV image would not work.

I have gotten some Jessie builds to run (Those are not the Site pulled version however).

Finally, since I need to pull a Wheezy built system (on Postgresql) into a Jessie built system (likely on LAPP, but perhaps just a tweaked Postgresql) it seemed practical to have a Wheezy method for replicating the build I have now as well as the Mods.

If I can get my head around the SSL changes that may suffice to work just with Jessie.  As noted though, would seem best if different versions would generally work on their own level.

(As an aside I would call "Jessie" v. 15 (for 2015)

Jeremy Davis's picture

The current LAMP and LAPP appliances both build fine for me on v14.0RC1 (Jessie) TKLDev.

In my tests SSL works (and TBH hasn't ever caused me any issues) so I'm not at all clear on what you mean there... However, the default Jessie Apache config doesn't support HTTPS (SSL) OOTB so perhaps that's what you're referring to? Regardless, commits I made recently (and have been merged by Alon) should mean that all appliances are now available via http or https...

L. Arnold's picture

I had checked out for a week.  In the interum it seems that Jessie TKLDEV etc are working better.  In that interum you had asked "why I was not keen on jessie".

The note above just spoke to why I was trying to get earlier versions to work (ie, trying to get a new App to build in various generations).  This was complicated by the "redirection goal" that was tied to the early SSL changes between Jessie and Wheezy and my difficulty in getting Wheezy TKLDEV to work in 64bit mode. (lets not go into that anymore, I think we are beyond it)

The new Updates are really great.  SSL issues have gone away on default appliances.  Just need to line up some of my configs for the Odoo.  Good progress on this today.

 

Jeremy Davis's picture

Awesome. Glad to hear that you can see progress happening from your perspective too! :)

The apace config that I posted for odoo on that other thread will most likely need some tweaking to get it to work properly with v14/Jessie though - things have changed a bit between Apache2.2 (v13/wheezy) and Apache2.4 (v14/jessie).

There is certainly progress all round though! :)

L. Arnold's picture

Wheezy Version that was captured at branch (defined of sorts) by

# cd /turnkey/fab/common
# git checkout c5107c75eb5f26a5237393d0f0428b9c719d2be7
# cd /turnkey/fab/products/tkldev
# git checkout 2359d0e3d31425388d9d312702e90b696c887c61

nearly built but Errored:

make: *** [build/stamps/root.build] Error 1

(trying to parse the error.  May have possibly just been a timeout, so running Make again.)

ROUND 2 Did WORK in terms of completing.  I will try the Modified TKLDEV ISO next.

L. Arnold's picture

probably needs another course.

THe ISO that TKLDEV created of itself (with branch's defined above) did not boot to install for me.

(could not find Kernel Image:  gfxboot)

lets not sweat this right now.  Back to Jessie 64 and 32 bit Wheezy for a bit. 

 

willem's picture

You can probably boot by just typing isolinux at the prompt, then enter.
 

L. Arnold's picture

even after reboot.  Still missing Kernel gfxboot

L. Arnold's picture

Would rather this comment show up above.  

 

It looked like I would need to Clone TKLDEV first so that Git is applied, then do the second checkout above.

I assumed assume from that that a new TKLDEV-MAKE make would be needed  to run on the TKLDEV folder, building a new ISO then using that as a basis for Wheezy TKLDEV processes.

Testing (and proceeding) now (see comments above on my current view anyway)

L. Arnold's picture

I may/should  have some more time tonight.

Working to get my working Odoo clean on 443 with no port number showing and have it be in LAPP.  Now it's in Postgres and hasn't migrated well yet.  It will though.

Purpose of an Odoo App is to simplify this of course.

Thanks again.

 

Lands 

Add new comment