Dennis Gray's picture

I have installed the turnkeylinux PostgreSQL appliance on a Virtualbox VM. The installation default was to install with NAT but I was unable to SSH nor get to the various tools via the web from my Windows host. I then changed the networking interface to bridged

After rebooting, the addresses assigned were on my network but I still cannot ssh nor access anything on the guests's browser.

From the shell on the guest, I can ping, which is the address of my router but cannot ping the Windows host nor anything else.

I have checked iptables and there are no rules.

Can anyone help?





Jeremy Davis's picture

NAT is great for Desktop OS type setups where you want to access the "outside" net but don't want the "outside" net to get access inside your vm. With a server you want "outside" net access to get in (after all that's the point of a server), so using bridged (or host only) is what you'll want. If you use host only then you'll probably want a second vNIC with NAT (so that your server can get updates etc).

When you complete the install it should show you the "confconsole" screen which will tell you the IP of your VM (assuming that you use bridged). You should be able to access it via your web browser...

Also AFAIK IMCP (which is what ping uses) is disabled in Win7 onwards (so by default it won't respond to ping unless you;ve specifically configured it so it will).

Dennis Gray's picture

  1. I am using bridged (see my post).
  2. My network is (see my post).
  3. DHCP is assigning to the VM.
  4. I am only trying to access the VM from my Windows 10 host.
  5. From cygwin, I can ping any other machine on my network so ping is not the issue.
  6. From the VM, I can ping the router and other machines on the network (not the Windows machine. I forgot that ICMP was disabled.​


So I am still stuck. I cannot access anything on the VM

Jeremy Davis's picture

It sounds like your settings are as they should be then... IMO there is no reason why it should not be working, otrher than some setting on your host (e.g. firewall).

The fact that the only machine that you can't access from within the VM makes me very suspicious of your host OS. Either it should work, or not; there is nothing inside the VM that should be affecting access to anything (as you note IPTables is disabled by default). It sounds like something is filtering/blocking your VMs networking access to your host OS...

The only other thing that I can think of is an IP conflict (that can cause weird stuff to happen - although I very much doubt that this is the cause). IP conflicts should be automatically avoided by using a DHCP allocated IP but perhaps there is an IP clash somewhere? Maybe try giving it a static IP that you know is not in use?

It sounds to me like there is an issue with VirtualBox and/or networking (on the host OS) and/or firewall (on the host OS or somewhere on the network).

Failing all that the only other thing I can think of is to try reinstalling VBox.

Dennis Gray's picture

This is a fresh install with no configuration changes.

I turned off the Windows firewall temporarily but no change.

From the Virtualbox console, I decided to install links to see if I can access the web services. I get a connection refused or connection reset by peer message, depending on which port I was using.

I then applied a static IP address that I know is not in use. Same problem.


Jeremy Davis's picture

Or were you saying that you were browsing localhost? You should have been able to connect fine to localhost internally regardless of what external networking is doing... Did you try accessing the internet?

You mentioned that it can ping other computers on the network. Can you access your server from other hardware on your network? E.g. in their web browser? There should be a simple page available via http(s).

Perhaps it's worth checking the integrity of the (ISO) image? Over the years we have had a few weird issues traced back to just ever so slightly corrupt download.

Maybe there is something up with your VBox install? VBox virtual networking setup? Something within the VM's config? I cannot think of anything that could come from the TurnKey install that would block access just to/from your host.

Maybe a workaround might be to add an additional virtual NIC and make it "host only"?

Add new comment