Strongwood Drums's picture

Hello, I created a brand new AWS instance using your Turnkey product. Everything was going well until I tried to log in to the back end of my Zen cart site.


I used the user Admin (tried both admin and Admin) and the password that I input upon creation.

Upon navigating to the login screen, this combo did not work. Neither did email+pw.

I then tried the Forgot Password feature. Entered my email, an hour later, no emails from the system. Email address is verified correct in DB.

Then I got tricky, i went to the DB, I changed the user's hashed pw (id 1 only user) with a string "here". Tried to log in with Admin/"here", again no go.


I am 100% unable to log in to the back end of my Zen cart system.


I would greatly appreciate your help!




Strongwood Drums's picture

Now I tried to try fresh with a second server.... everything appears well and good in the Dashboard and my EC2 console.... but the server does not respond at all, not to HTTP or SSH..... ?


going from bad to worse here

Jeremy Davis's picture

Is this a v14.0 server or v13.0?

I will test a v14.0 ZenCart appliance ASAP and report back...

I am not particularly familiar with ZenCart but if this is particularly urgent then it may also be worth investigating what upstream suggest. Often upstream software providers have instructions on doing a manual admin password reset...

Regarding sending of emails, unfortunately AWS servers sending emails can be a bit hit and miss... This is because AWS servers so often get abused and used for spamming. Then the IP gets blacklisted for sending spam and many email hosts (silently) block emails from blacklisted sources (which your AWS IP may well be if one of the recent users of that IP was a spammer).

Strongwood Drums's picture

Thanks for the suggestion Jeremy- I did notice the upper/lower case issue, and I tried both Admin and admin... neither work.

Also, this brand new server wouldn't be blacklisted for anything. It has never sent a single email, let alone spam.


Jeremy Davis's picture

So perhaps it has some password complexity requirements that the initialsation script doesn't enforce (so it allows you to set an invalid password)? Or as I suggested in my comment below, maybe your password includes a special character that ZenCart doesn't like? Or if you're not using a US keyboard perhaps it mis-interpreted (some of) the password? Or maybe something as simple as you accidentally had the caps-lock on when you set (or entered) the password?

I think probably the best way to go at this point is to reset all the Zen Cart initialisation settings. If you log in via SSH (or use Webshell) you can manually re-run the Zen Cart initialisation hook and use a known good password ("Passw0rd"). Then you should be able to log in and use the Zen Cart admin interface to reset the password to something more secure.

This is the command to run on your server:


Make sure that you set the domain to be what it currently is.

Re blacklisted email. AWS IPs are dynamically allocated so if the IP has been blacklisted (by spam being sent from that IP) then the age of the server is irrelevant. Probably the best way to avoid that is to use an elastic IP and ensure that it is not blacklisted.

Jeremy Davis's picture

I just had a bit of a muck around with the v14.0 appliance and discovered that it requires the username to be Admin (note the capital 'A'). Other than that everything appears to work as it should.

We probably need to document this to avoid future frustration...

Oops I just realised that you noted that you tried with a capital A. That's really weird as it works fine for me... Are you using a standard US keyboard? Does your password have any special characters that may be causing an issue?

Add new comment