L. Arnold's picture

I've struggled w/ this in the past, now I need to fix it in that my old install is Kaput.

Having just dropped a week old TKLBAM onto a fresh Magento (13) install - same gen, any thing that aims at the domain(s) or Ip is presented with the /var/www  root, rather than the /var/www/magento root.

I don't see any "exclusions" in the TKLBAM profile.

Any one know how to fix this so I get magento working?

thanks in advance.

L. Arnold's picture

this is what the page looks like.  not really hitting Magento till the folder is chosen.

Unfortunately there Magento has it's own rewriting rules which complicates everything.

Long story short - Can't get into the Magento System.


Magento Appliance - Powered by TurnKey Linux

Index of /

[ICO]NameLast modifiedSizeDescription

[DIR] magento/ 05-Jul-2012 10:48 -  
Apache/2.2.22 (Debian) Server at www.mydomain.com Port 80
L. Arnold's picture

Strangely the TKLBAM process DID rewrite my Root Password but did not Rewrite my MySQL Password.

Magento needs MYSQL Acccess...  so a little more fishing.

Looks like Magento is not accessing the Database...  OK...  now what...  Where is Magento storing that Password?

SQLSTATE[28000] [1045] Access denied for user 'magento'@'localhost' (using password: YES)

#0 /var/www/magento/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /var/www/magento/lib/Varien/Db/Adapter/Pdo/Mysql.php(313): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /var/www/magento/lib/Zend/Db/Adapter/Abstract.php(459): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /var/www/magento/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /var/www/magento/lib/Varien/Db/Adapter/Pdo/Mysql.php(419): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /var/www/magento/app/code/core/Mage/Core/Model/Resource.php(169): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /var/www/magento/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element))
#7 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(320): Mage_Core_Model_Resource->getConnection('core_write')
#8 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(350): Mage_Core_Model_Resource_Db_Abstract->_getConnection('write')
#9 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Db/Abstract.php(335): Mage_Core_Model_Resource_Db_Abstract->_getWriteAdapter()
#10 /var/www/magento/app/code/core/Mage/Core/Model/Resource/Cache.php(53): Mage_Core_Model_Resource_Db_Abstract->_getReadAdapter()
#11 /var/www/magento/app/code/core/Mage/Core/Model/Cache.php(455): Mage_Core_Model_Resource_Cache->getAllOptions()
#12 /var/www/magento/app/code/core/Mage/Core/Model/Cache.php(497): Mage_Core_Model_Cache->_initOptions()
#13 /var/www/magento/app/code/core/Mage/Core/Model/App.php(1183): Mage_Core_Model_Cache->canUse('config')
#14 /var/www/magento/app/code/core/Mage/Core/Model/Config.php(414): Mage_Core_Model_App->useCache('config')
#15 /var/www/magento/app/code/core/Mage/Core/Model/Config.php(294): Mage_Core_Model_Config->_canUseCacheForInit()
#16 /var/www/magento/app/code/core/Mage/Core/Model/App.php(413): Mage_Core_Model_Config->loadModulesCache()
#17 /var/www/magento/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#18 /var/www/magento/app/Mage.php(683): Mage_Core_Model_App->run(Array)
#19 /var/www/magento/index.php(87): Mage::run('', 'store')
#20 {main}
Jeremy Davis's picture

If you haven't rebooted post restore then I would do that first (or restart all the services).

Re your MySQL connection issue, the first thing to check is if MySQL is running:

/etc/init.d/mysql status
service mysql status
And if it's not running, start it (as per above except with "start" instead of "status").

Re your website, first thing I would check is what Apache sites are enabled:

ls -la /etc/apache2/sites-enabled

By default it should just show you "magento" (or "magento.conf" for v14.0). If it shows "default"/"000-default" then run the following (as relevant):

a2dissite default
service apache2 restart
However your backup shouldn't be breaking your appliance like that. Personally I'd be looking into your backup and the restore process a little deeper...

Add new comment