Dark000's picture

I installed moodle turnkey version 14. Then I migrated moodle and the ldap settings are not working. The old server is installed with version 13 and there same ldap settings are working fine. I also tried to input ldap settings in the existing default moodle instllation on new server(14), but i get the same error. Please help.

LDAP-module cannot connect to any servers: Server: 'ip:3268', Connection: '', Bind result:

I noticed in changelog for V14:

- Includes support for authentication via ldap (convenience).

What does that mean, could that be the couse of error.

I also checked phpinfo.php and on the new server there are under extension both ldap and ldaps, where on the old server there is only ldap. How do i remove ldaps if that is the problem?

So the same ldap settings that work on debian 7.6 are not working on debian 8.2

Jeremy Davis's picture

Although obviously the OS itself has been updated. I would suspect that there was probably something that was an explicit dependency in Wheezy but isn't in Jessie. Upstream probably have some troubleshooting steps...

Also the changelog entry you mention is from 2009 so I doubt that would be the issue. Although perhaps something got broken with the setup since then?

Dark000's picture

I was also in the dark with this, but i manage to solve it. It has to do with new version of php 5.6 which doesn't accept Host URL with IP:PORT as we had this setting all these years.

Now it has to be ldap://IP:PORT

So all there was to do was to add "ldap://" infront of the ip. Easy fix which is very hard to find.

Jeremy Davis's picture

I am sure that others will find that info handy! Great detective work BTW!

Add new comment