Mando's picture

Hi guys I am using debian-7-turnkey-lighttpd-php-fastcgi_13.0-1_amd64.tar.gz

Playing with proxmox I added an IP Address with venet. Now everything is defaulting to that address and I can't seem to change it.

ifup eth0 brings eth0 back up but I cannot assign any meaningful attributes to it. it fails when trying to add an IP Address or netmask.

For example when I attempt to add address it says:
Hostname Lookup Error

 

Any idea on how I can get eth0 back up?? I already removed the venet address from ProxMox. I've tried re-adding interfaces inside proxmox but when i reboot the turnkey container i see in the messages it's still stuck on that bogus IP i added. Any guidence would be greatly appreciated. Thank you.

Forum: 
Jeremy Davis's picture

Personally I just use venet with almost all my containers anyway. IMO a server should have a static IP so using venet makes that super easy. I have also read that it is much more secure.

But I am aware that some software doesn't like using a venet (e.g. Samba, BIND, etc) and for those ones I use the bridge (veth) which will provide a "eth0". I would expect it to work mixing these (though I've never tried - and your experience suggests not).

The first thing I would check is that the container networking is providing a veth network (to provide ethX). If not add one! Also perhaps removing the venet network too?

Mando's picture

Hey so if anyone is dumb like me or was just not thinking i got it working! :)

 

I was doing all sorts of reading and tried some stuff with udev and was playing with ifconfig. Using ifconfig I was able to bring the interface up and get it an IP address (I used the wrong syntax before!). However I still couldn't resolve hostnames or reach the internet.

 

I did

nano /etc/network/interfaces

and added

    auto eth0
    allow-hotplug eth0
    iface eth0 inet dhcp

And now I'm back up!

 

References: https://wiki.debian.org/NetworkConfiguration

http://unix.stackexchange.com/questions/124269/where-is-my-eth0-configur...

https://openvz.org/Veth

Paul's picture

For internet check your gateway in ifconfig (is it the right ?)

For the DNS check the file : /etc/resolv.conf

there should be a line like :

nameserver x.x.x.x

where x.x.x.x is the ip of the DNS of your choice

 

Add new comment