Brian Nelson's picture

I run MineOS on two boxes at my house, this is a distro based on turnkey running minecraft servers. I've already asked for help there and nobody seems to know, so let me try here. I'll paste what I wrote there. Any ideas would be super appreciated!

 

I have two boxes running the turnkey linux and they've been great, but exactly yesterday, both stopped responding to my samba shares that had worked for a year+ without problem. I'm thinking something got updated and now I need to know how to fix.

I looked at my smb.conf file, which even though it looks right, I noticed the last change was also yesterday. So i think something in there changed, but for the life of me, I can't tell what!

Tried re-adding the root user (I do this as root so I can modify anything in the entire file system from my windows machine) using pdbedit and that didn't do anything. Restart the server, nothing. Tried adding allow user and force user, nothing is working.

Any ideas? Thanks!

 
 
Forum: 
Tags: 
Mattias Granditsky's picture

I have exactly the same problem with 2:4.3.3-0.fc23 on Fedora Server 23.

All other shares work fine except the root share. Modifying the share to just point to a subdir instead works fine.

I can connect and list the root fine, but as soon as I try to enter a subdir, I just get access denied or network error.

Tried with clean smb.conf and a lot of things (other users etc). Nothing worked.

I reverted to 4.3.0 and all is well.

Brian Nelson's picture

Thanks for the comment, that sounds exactly like what is happening. I can see the directory structure of / but as soon as I try to go into any of the subdirs, I get denied.

I could probably do what I need to do with just /var. I only ever really go into the game servers, the logs, and the www folder. But just for the sake of being thorough, can you tell a linux novice how to downgrade samba? Moreover, how to prevent it from updating again in the future? It seems to have done this all on it's own. It worked fine for a year+.

 

Mattias Granditsky's picture

Wish I could help you there. Mine is a virtual machine that I just took a snapshot of before running an update (I do not have automatic updates on), so I just reverted to the last snapshot.

 

In Fedora/Redhat, I would otherwise have uninstalled Samba with yum remove samba (or dnf remove samba for fedora 23) and then found a previous version (4.3.0) in rpm format to install instead. No clue how to turn off automatic updates in MineOS to be honest =(

 

Mattias Granditsky's picture

We can verify that it is indeed the same problem though. Run smbstatus and check version.

4.3.3 was the one giving me grief.

 

Brian Nelson's picture

If I remember right, it's actually 3.6.6. But I'm pulling that from memory. I have no idea what version would have been installed prior to that.

At any rate, I'll try /var instead of / and see how it goes tonight. That will at least get me back up and functional.

 

Brian Nelson's picture

Mattias, thanks for your help. It's not an ideal solution, but I changed my share to /var instead of / and it works again. I can probably do 99% of what I need to do this way. The 1%, I'll just putty in. Thanks for the help! This is closed!

 

Jeremy Davis's picture

Sorry I'm a little late to the party, but considering that both of you are having the same issues (despite different OS and versions of Samba), my guess is a security update patched some security issue (further supported by the fact that TurnKey auto installs security updates). I'm guessing that the functionality of your config relied on something that has now been patched (or perhaps that was just a side effect). My guess is also backed by the fact that there was an "urgent" security related update on Dec 22 (see the Debian Wheezy Samba changelog here).

FWIW personally I generally avoid Samba as IMO there are many other (better) ways to connect to Linux server. I use only Linux these days so it's a bit of a moot point (and I'm obviously biased!) When I did run Windows if I only needed occasional filesystem access I just used Filzilla (SFTP) or if I wanted a directory mounted all the time (like Samba provides) then I used WinSSHFS. The bonus of both of those methods is that it uses default connectivity (SFTP/SSH - both which are provided OOTB on TurnKey) and requires no server side config or additional servcies running (and minimal work on the desktop side).

Anyway...

Mattias Granditsky's picture

Seems fixed in future builds. Also ugly workaround provided
https://bugzilla.samba.org/show_bug.cgi?id=11647

Jeremy Davis's picture

Thanks for posting Mattias. Hopefully Debian will apply this fix sometime soon. Until then at least there is a workaround (albeit a bit ugly as you say).
Varun Agrawal's picture

I just found another workaround it. Enable symlinks.

Add this to your smb.conf

[global]
    wide links = yes
    unix extensions = no
 
Dimas's picture

The same situation here with Ubuntu Server 14.04.


Thx Varun! It worked.

Jeremy Davis's picture

Debian released a new Samba security update last week and I noticed in the changelog that they stated that this regression should now be fixed...
joe haddad's picture

This is the only place I foun a fix for my path = / problem that used to work before.

For this reason linux sucks sometime.

 

 

Add new comment