I'm trying to build spandsp from the conf script when running "tklpatch-apply / turnkey-patch". 
Source code for spandsp is included in the turnkey-patch directory. 
From the conf script I do the following: 

cd /source/spandsp-0.0.6 

But it fails with: 

cd . && automake-1.13 --gnu
/bin/bash: line 4: automake-1.13: command not found 
Makefile:421: recipe for target 'Makefile.in' failed
make: *** [Makefile.in] Error 1

I found a work around and that is to include the tar file, for the source code, in the turnkey-patch directory and in the conf script I do the following: 

cd /source
tar -xzvf spandsp-0-0-6.tar.gz
cd spandsp-0.0.6 

That builds spandsp as expected. 
I do however prefer to put the source code for spandsp in my local version control repository rather than the tar file. 

Does anyone have any ideas about what is causing the error that I get? 

Kind regards 

Jeremy Davis's picture

TBH I have no idea why it works ok when you include the archive, but not when you don't. It's very weird... My initial thought was that perhaps build-essential wasn't installed in your system, but actually that doesn't explain it at all (it should still fail regardless of whether it's coming from a tar or not).

One thing you could do to test it further is do the patching process in stages. If you have a look at tklpatch source code you will see that it runs a series of sub commands. You could try running those individually then chroot into your rootfs and manually run your commands. It should produce the same error and perhaps you could try troubleshooting it then?

Actually now I think about it more, perhaps there are some important hidden files that aren't being copied across (but are in the archive)? Or perhaps it's something to do with permissions (tar archives retain relevant permissions whereas your copying possibly doesn't)?

Thanks for the response!

I decided to keep it as it is with the tar-file. If I get time to work on it further, I will check permissions, hidden files etc.


Kind regards


Add new comment