Steve's picture

I've built three! Two on ESX 6.0 and one on Mac Fusion 8, and on none of them can I login to rtorrent interface or even admin with the password I input on install.

What exactly do I put in the web login screen for the ruTorrent area?

I sense I'm being stupid.....

Steve's picture

Solved, the username is 'admin' - not sure that's clear in the install.... Now I'm getting  No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file. - next stage!




Jeremy Davis's picture

FWIW each appliance has it's own page (e.g. torrentserver).

As for your latest issue, we will be releasing improved v14.1 appliances shortly to resolve this and some other issues... In the meantime try the following:


wget -O /$FILE $URL/$FILE
chmod +x /$FILE
service rtorrent start
Steve's picture

Cheers! Sorry for now posting in correct place - new boy, I'll get there! I fixed my issue by deleting rtorrent.lock and restarting, I'll try another build with your suggested fix for quick deployment but looking forward to 14.1 - good work fellas, we don't have this sort of think on AIX!



Jeremy Davis's picture

I made a couple of mistakes in my post above but I've fixed it now.

And you've posted in the right place. I just wanted to let you know about the appliance pages so if you use another appliance you'll know where to look! :)

The other issue that I alluded to (and will be fixed in v14.1) is missing dependencies for full ruTorrent functionality. You can apply that fix like this:

apt-get update && apt-get install mediainfo libav-tools
sed -i "/curl/ s|> '.*'|> '/usr/bin/curl'|" $DIR/conf/config.php
sed -i "/ffmpeg/ s|= '.*'|= '/usr/bin/avconv'|" $DIR/plugins/screenshots/conf.php

Add new comment