Just tried to install virtualmin on current 14.0 LAMP and get as follows. See below. Has anyone got virtualmin running ?

debconf: delaying package configuration, since apt-utils is not installed
then after a while
Errors were encountered while processing:
WARN - apt-get seems to have failed. Are you sure your OS and version is supported?
WARN - http://www.virtualmin.com/os-support                                                                                             
FATAL - Fatal Error Occurred: Installation failed: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log
Jeremy Davis's picture

They aren't available from the TurnKey repo. Perhaps they are incompatible with the version of Webmin in TurnKey. Or perhaps the packages that you are trying to install aren't compatible with the version of Debian TurnKey is based on.

Also FWIW the latest version of Webmin is now in the TurnKey repos. I detailed how to upgrade on this post on our Issue Tracker.

This is with latest LAMP v14.0 plain vanilla downloaded last week with webmin  1.76.  All I have done is download and run standard virtualmin install script so quite surprised i get these errors.  To check I just tried again with same result.

I used the install script here


Same error as above

Also tried the module route


But got error Failed to install uploaded module : Module virtual-server requires module procmail

And tried uploading the deb file

dpkg -i webmin-virtual-server_5.01.gpl_all.deb


This Webmin module depends on the module quota, which is
not installed on your system.
dpkg: error processing archive webmin-virtual-server_5.01.gpl_all.deb (--install):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
Also tried apt-get install apt-utils  to fix first error but got
Package apt-utils is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
Then tried
apt-get update
apt-get upgrade -y
apt-get install webmin-filemin
and ran install.sh again. with same result
Tried all methods again with same result on updated version.
As it stands it seems you cannot  install virtue in on the current default turnkey LAMP appliance
apt-get update
apt-get upgrade -y
apt-get install webmin-filemin




Jeremy Davis's picture

When you tried the module route it's missing the Webmin procmail module. That's easily fixed:
apt-get install webmin-procmail
It may complain about something else after that but try installing that too.

When you tried the different route of installing the deb, again it was missing a dependency, this time quota. IMO the easiest workaround for installing a deb file and all it's dependencies is like this:

# force dpkg to ignore dependency issues
dpkg -i --force-depends webmin-virtual-server_5.01.gpl_all.deb
# use apt to resolve the missing dependancies
apt-get update && apt-get install -f
FWIW it looks like the install script just adds a repository entry and then apt-get install virtualmin and all it's dependencies. It also has an uninstall routine. When I get a chance I'll have a closer look at it...

Thanks Jeremy, Ive got it going as follows via the module install route. you need to run  as follows.

apt-get install webmin-procmail
apt-get install webmin-mailboxes
apt-get install webmin-quota
apt-get install webmin-bind8



Cheers, Paul

Jeremy Davis's picture

Glad to hear that you got it working. FWIW you could condense those lines to a single line like this:
apt-get install webmin-procmail webmin-mailboxes webmin-quota webmin-bind8
Also please be aware that installing the Webmin modules doesn't actually install the server functionality (e.g. to use the Webmin bind8 module you have to have bind9 installed - you can safely ignore the bind version mismatch). So whilst you now have Virtualmin installed it still may not be able to do everything it wants to.

Having said that it is possible that the Virtualmin installer takes care of installing those dependencies.

Revisiting this as didnt manage to get it live last time round. I am getting

"Module webalizer does not exist"

Then I got

"Module logrotate does not exist"

If you go to unused modules in webmin you get this

"The logfile analysis command /usr/bin/webalizer was not found on your system. Maybe it is not installed, or your module configuration is incorrect.

The Webalizer package can be automatically installed by Webmin.

to have it downloaded and installed using APT."


Been through a couple of loops updating via software packages menu. Virtualmin has a check config option. If you keep checking eventually you can get it to work.

might be worth considering a webmin/virtualmin appliance





For reference after you get virtualmin running you then get a whole series of errors re apache modules when you list virtual server. it's annoying because you only get one error every time you check the configuration.

"The Apache module mod_actions is either not installed or not enabled."

"The Apache module mod_actions is either not installed or not enabled."


Apache configuration file /etc/apache2/mods-enabled/php5.conf contains SetHandler lines that prevent PHP from running with domain owner permissions. These lines must be removed.

.. your system is not ready for use by Virtualmin."

"Failed to save website options : The Suexec command on your system is configured to only run scripts under /var/www, but the Virtualmin virtual server home directory is /home. CGI and PHP scripts run as domain owners will not be executed."

Given up.



A virtualmin appliance with php 5.6 and 7 as per


Would be nice

Jeremy Davis's picture

That's a cool idea, but I would be wary of using php7 in production just yet (unless you need to). Although a development server with it could be cool.

TBH we haven't had a ton of users requesting VirtualMin and TBH I wasn't even aware that there was an open source version but seeing as there is it could be quite a cool option.

Unfortunately we have our hands full at the moment, but if you wanted to work on please have a look at TKLDev

I wouldn't trust myself to attempt to tinker with the development version. PHP 7 is very fast for cms websites (we use Joomla and it was getting slower with every release) however it's a real pain migrating sites as  you need support for multiple PHP hence my request. The latest version of Plesk supports multiple php however I haven't managed to get Plesk running on turnkey yet. Will try this route.



Jeremy Davis's picture

I didn't mean that php7 isn't stable yet. I was more referring to the maintenance side of things.

TurnKey is pre-configured to auto install security updates for all software installed from the official Debian stable (currently Jessie) repos. But seeing as php7 is not currently available in the stable repos, that isn't an option. So if you were to go that route you would need to ensure that you were very vigilant with php updates. Often that means that you'll need to update php7 version as it is released. That may cause issues in the future. E.g. if php7 is updated due to a security bug, but there are new changes in the new version which your software isn't compatible with...

But I did do a quick google and saw that Joomla in particular seems to be much faster with php7 so thanks for the info.

Add new comment