Jack Murphy's picture


I have recently begun coding an application on Android Studio, I followed a number of tutorials for creating login and registration pages. I set up the TKL mysql server and have been trying to access it from the Android emulators but I seem to be getting the same error over and over again. From what I gather it is to do with the Certificate Authorities for the server. If anyone has a solution to this it would be much appreciated as I am new to the networking side of things and haven't got much experience.

My errors:


Jeremy Davis's picture

Have you tried googling the error? Assuming you are using the TurnKey MySQL appliance then there should be nothing on TurnKey causing this. FWIW all the other appliances that include MySQL (e.g. LAMP) have it locked down and only available from localhost.

Also by default TurnKey uses self signed certificates. Perhaps that is part of the problem? Maybe you need to add your self signed cert to the trusted certs in your Android emu?

If you keep in mind that under the hood TurnKey is Debian (v14.x = Jessie) then you should find tons of relevant info online.

Having said that, if you find a solution it'd be great if you post back as others may find your info handy.

Add new comment