rtorrent 14.1

vigilian's picture

First I want to congratulate you about resolving the bug. 14.1 works perfectly.

I need some advices. I would like to put on the same range of port the administration and the rtorrent needs of ports. more easy to transfer the webmin port or more easy to transfer the rtorrent ports? where are the configuraiton file of rtorrent on your tempalte by the way? because I couldn't find anything in /etc/rtorrent. it seems that I can't change the ports in the interface, at least it didn't recall my sttings after each reboot.

by the way did you configure something in the iptables ?

Or maybe should I port forward all the port to be near the rottrent range port

Jeremy Davis's picture

Are you wanting to change the ports that rtorrent uses?

If so I will have to investigate and get back to you as I'm not sure OTTOMH.

IPTables are configured but not enabled by default.

As I said I will have a look and get back to you ASAP. In the meantime you could use IPTables to adjust the ports if you desire (i.e. listen on some new ports and forward them (internally) to the current rtorrent ports. Alternatively you could also use the port forwarding capabilities of your router (assuming it has them) to listen on different external ports and foprward them to the existing ports on your torrent server.

Also out of curiosity, others have noted that in the v14.1 appliance, installing the security updates and/or rebooting the server breaks the Nginx webserver component of the torrentserver appliance. Have you experienced that?

[update] I noticed from your other thread that you are using LXC containers in Proxmox 4.1. That explains why you are not experiencing the issue. I couldn't reproduce it in a container either but am now installing a VM to try to work out what the issue is.

dominique120's picture

As far as I know the configuration for rtorrent is at "/var/lib/rtorrent". The configuration files is called ".rtorrent.rc".

I'n not 100% sure though since I have not had alot of time to play with it yet.

 

If you are looking for a file you could always use the find command like so: find -name "query"

since we are dealing with hidden files use the -a flag if you want to ls the directory

and of course use grep if there is to much stuff on the ls output: ls -a | grep "rtorrent"

vigilian's picture

Okey I will try to be more clear about my wish.

I would like to prefer to have the port of the webmin interface neighbour of the rtorrent port. So I wanted to know if it was maybe more easy to change the rtorrent port (which are in .rtorrent.rc) or the webmin interface port(I don't know if it could be change in some configuration file)? Or maybe both of these interfaces are really too much of a mess for a change because too much dependencies of what you configured in your template and really we shouldn't change the port configuration at all?

The other question was about the location of .rtorrent.rc

and the final question was that if the iptables was activated (drop policy in the INPUT table)

vigilian's picture

ow also,

I would like to simplify the rules in my router that's why I want some continuous port of a specific ip adress

Jeremy Davis's picture

  • AFAIK rTorrent ports can be configured in it's config file (as you already seem aware).
  • Webmin is hidden behind stunnel so you can adjust that port in /etc/stunnel/stunnel.conf
  • ruTorrent (rTorrent web interface) is served by nginx so if you want to adjust it's port then edit /etc/nginx/sites-available/rutorrent (not that you asked just thought I'd add that!)
  • c0mputerking's picture

    I have changed my port number to 2226 in /etc/nginx/sites-avaliable/tkl-webcp like this
    listen 2226 default_server;
    listen [::]:2226 default_server;
      I have left all other ports alone ow tkl-webcp appears on the port i specified (2226) however when i try to use the links on the foremention page example rutorrent they do not work ... and the links are weird they add the new port number first.  https://10.22.0.111:2226:12322
    Jeremy Davis's picture

    I'm not very familiar with anything but the basics when it comes to Nginx. But I'm guessing that you may need to adjust the auto generated URLs which the default index.php file provides.

    By default, the URLs are dynamically generated from the URL the page is accessed from. We do it that way, so they work for anyone no matter how they access their appliance (e.g. IP address, custom public FQDN or even a local private FQDN.

    It appears that once you change that to a non-default port, the port is also included as part of the base URL.

    The only options that spring to mind are:

  • hardcode the links to a specific FQDN/IP (obviously you'll want to set a static IP or DNS as appropriate)
  • Use some sort of regex URL rewrite to strip the port number from the base URL (I'm not 100% sure how to do that in Nginx - but I'm sure it's possible)
  • Post new comment