Forum: 

Redmine Virtual Appliance Git Repository 404 "The entry or revision was not found in the repository"

Scott's picture

I just launched a Micro Redmine server on AWS.  When I go to Projects>git-helloworld>Repository I get 404 - "The entry or revision was not found in the repository".  I have tried destroying and re-launching a new appliance.  I have tried adding a new repository. Any guidance would be greatly appreciated.  

Scott's picture

I also tried to create a new repository using the istructions at https://www.turnkeylinux.org/forum/support/20100914/how-setup-git and got the same behavior on the new Project.  It seems the link in the Redmine virtual appliance to Git repositories is somehow not working.  I can select Repository for the other projects, just not Git projects.

Jeremy Davis's picture

Thanks for your report and sorry to hear of your issues.

Is this launched from AWS Marketplace? Or the Hub?

Also can you please confirm the TurnKey version? If you are not sure, please post the output of "turnkey-version".

Regardless, I have opened an issue on our tracker: https://github.com/turnkeylinux/tracker/issues/691

[update] I have just confirmed this issue in v14.1. Apologies that this slipped through our testing. We'll work on a fix.

Jeremy Davis's picture

However, I haven't been able to pin down the cause just yet. However, I haven't been able to reproduce the issue with a new repo. I can successfully add a new git repo and that works as you'd hope.

This is the process step-by-step that I used to test:

  1. Make new repo:
    mkdir -p /srv/repos/git/tester
    cd /srv/repos/git/tester
    git config --global user.name "test committer"
    git config --global user.email "test@example.com"
    git init
    echo "this is a test file" > test-file
    git add .
    git commit -m "initial commit"
    
  2. Create new project:
    • "Projects" > "New Project"
    • I called mine "test-project" and used that for the identifier as well.
    • Click Create
    • Browse to new project, click Settings tab; click Repositories sub-tab
    • Click "New Repository"
    • Select "Git" from SCM dropdown, other details as relevant
    • For URL I used the file path to .git subdir of my git repo:
      /srv/repos/git/tester/.git
    • Click create
  3. browse to new repo and there it is! :)
Jeremy Davis's picture

I just re-read your OP and also the tutorial that you said you followed and compared it to what I just wrote. The significant difference is that those instructions point to the base directory of the git repo; rather than the .git sub-directory (which contains all the git info like commits etc).

Looking at the source code for the appliance it appears that the build code (when the appliance was last rebuilt) made the same mistake. I'm not sure if this is due to some sort of change in Redmine or git, or whether it's been a regression in our build code. The fact that the tutorial you link to also makes the same mistake makes me think that something must have changed in Redmine and/or git...

Regardless, it turns out that the bug was noted previously and a fix provided for the appliance, but the app hasn't been rebuilt since then... So silly me just wasted a ton of time on something that was already fixed... Doh! So we just need to rebuild the appliance so this bug is no longer there...

Scott's picture

Jeremy,

Thanks for your replies.  I was using the Hub, sorry for the confusion.  And thanks for your effort.  I was able to add a new Repository to the Project with the corrected directory name and Voila!  Thanks again for taking the time to get me on track.

Post new comment