Forum: 

Getting the mailserver to work in the Turkey WordPress Appliance

Evert Wagenaar's picture

Hello all,

I'm running a TurnKey WordPress Appliance from my home. It runs inside a fast MacBook Pro with 16 Gb RAM and a 512 Gb SSD. I'm happy with the speed of the WordPress pages being served (after a lot of optimization of the Caching and a Bash script to get and keep all my pages cached.

I now would like to get the PostFix mailserver to work for me. As usual my ISP is blocking port 25 so I guess I need a workaround for this. To my knowledge there should be 2 solutions:

1. Using a relay Server. I read somewhere that gmail could be used for this.

2. Using TLS. This encrypts all mail and uses a different port which the ISP leaves alone.

Off course I also want to receive mail using Dovecot and IMAPS.

 

Could anyone send me some CLEAR manuals on how to do this within the TurnKey WordPress Virtual  Appliance?

Many thanks.

Evert Wagenaar

http://www.evertwagenaar.com/

Evert Wagenaar's picture

easy wp smtp plugin 
Settings:
smtp.gmail.com
ssl
port:465
Evert Wagenaar's picture

Hi all,

I accidentally used a wrong email address in the Easy wp smtp plugin. I changed the settings in the plugin but it keeps sending the mail to the wrong address.

i tried to look inside the DB but it appears Webmin isn’t working anymore.

Any ideas for alternatives for Webmin?

Or how to repair it?

Where are the easy wp plugin settings stored anyway?

 

Many thanks 

Jeremy Davis's picture

TurnKey already comes with Postfix configured to send emails directly. So in theory you don't need to configure SMTP. However, sending email directly is fairly hit and miss unless you are an email expert. So the next best option is to configure a third party SMTP relay (essentially what the WP plugin you are using does, but at a system level rather than via PHP).

Using a WordPress plugin will have more system overhead than simply configuring the system email sending to go via a third party SMTP relay. In our latest release (v14.2) we include an easy interactive way to configure it via confconsole. For versions prior to v14.2, we have a generic doc page that covers the basics, plus some explicit info for specific third parties.

Having said all that, if it's been working ok (other than these current issues) then going in a different direction may not be the quickest way to achieve your ends.

Regarding the explicit issue you are having with Webmin, please log in via SSH and try the following:

service webmin status
If that reports a status of anything other than "active (running)" please try starting it:
service webmin start

If that appears to start ok, but Webmin still isn't working, please check the stunnel service:

service stunnel4 status
Again if it returns anything other than "active (running)" then try starting it:
service stunnel4 start
If that still doesn't resolve it, can you please tell me what version of TurnKey this is. If you're not sure, run this:
turnkey-version
PS if you want to access MySQL, then perhaps Adminer (https via port 12322) might even be a better option?

Post new comment