Out of the box Redmine issue

Donald's picture

Hi

I've downloaded turnkey-redmine-14.2-jessie-amd64.ova and created a vanila VM.

As soon as the vm is configured (setting all the passwords and email addresses) and it powers on I start getting email alerts with the following subjuct:

Cron <root@redmine> ruby $WEBROOT/extra/svn/reposman.rb --redmine localhost --svn-dir /srv/repos/svn --owner www-data --url file:///srv/repos/svn --key-file $WEBROOT/api_key 2>&1 >> /var/log/reposman.log

In the body of the email i have this:

/bin/sh: 1: ruby: not found

I've tried building the VM several times, I've also tried with and without installing the security updates and all result in the same issue.

I guess it relates to the following cron job that runs every minute

ruby $WEBROOT/extra/svn/reposman.rb --redmine localhost --svn-dir /srv/repos/svn --owner www-data --url file:///srv/repos/svn --key-file $WEBROOT/api_key 2>&1 >> /var/log/reposman.log

Can anybody help please?

 

Thanks

Donald

 

 

 

Jeremy Davis's picture

Thanks for posting with your issue and deep apologies on the delayed response. Despite the lack of obvious activity, we're flat out behind the scenes trying to push out the next release (v15.0).

One of our developers is looking into it now. He'll post back with a workaround ASAP.

Donald's picture

Hi Jeremy

No worries, I though your response was more than timely. Evgeniy has already come back with a fix so I'm away to test that shortly.

Thanks again and keep up the good work.

 

Donald

Jeremy Davis's picture

Ideally, I'd love to be able to respond quicker, but I do really appreciate your patience and general attitude. Thanks for being so accommodating.
Evgeniy's picture

Hi Donald,

The problem is rbenv not being loaded into cron job's shell environment. This can be fixed by adding rbenv executables into its PATH variable, so the way you can fix this would be changing this cron job to this.

PATH=/usr/local/rbenv/bin:/usr/local/rbenv/shims:$PATH ruby $WEBROOT/extra/svn/reposman.rb --redmine localhost --svn-dir /srv/repos/svn --owner www-data --url file:///srv/repos/svn --key-file $WEBROOT/api_key 2>&1 >> /var/log/reposman.log

I also created a github issue at out tracker, so you can monitor any activity related to fixing the issue in the future.

https://github.com/turnkeylinux/tracker/issues/993

Thanks :)

Donald's picture

Hi Evgeniy

 

Thanks that did the trick - I get another error now

Unable to read the key from /var/www/redmine/api_key: No such file or directory @ rb_sysopen - /var/www/redmine/api_key

 

I'll have a look about to see if I can see what the issue is with the api_key.

 

Thanks for your help

 

Donald

Post new comment