Ping Ning's picture

I downloaded the ISO for latest standalone tomcat (15.1 stretch) and used rufus to put it on a USB drive. I was able to install it on a Lenovo T420 which is a UEFI boot machine. But the machine won't boot from hard drive.

I download ReFind from and put it on a CD then used it to boot up the machine. It worked. I checked the machine and the /boot and /boot/efi seems proper.

I have tried numerous tricks but failed to boot the machine off the hard drive. Any help or suggestion are very much appreciated.  

Jeremy Davis's picture

TBH I have zero experience booting from a UEFI enabled device. My recommendation would be to disable it if possible (AFAIK re-enabling legacy BIOS function should be possible?) and just do a normal install.

If you want to persist with getting UEFI working, then by my understanding, you'll need to have a few things set up. You'll need to ensure that the disk has a GPT (as well as/instead of an MBR). And I vaguely recall mention of a specific additional UEFI partition?! But I'm not sure if that's right, or even if it is, how you correctly go about adjusting that.

Also, I'm pretty sure that you'll need to install the grub-efi package. Actually, it looks like that's just a meta package, and the one you really want is grub-efi-amd64.

Although, perhaps that grub-efi is all you really need?!

Sorry I'm not that much help, but hopefully you have some luck?! If you do and/or need any more hints/random thoughts, please feel free to post back. It'd be super handy if you do have any success if you shared how you do it.

Add new comment