Garreth's picture

Iv'e attahed a CIFS share via Webmin, its mounted and can browse the content. Mounted as /mnt/sharepoint

Iv'e tried adding this as a watched folder in Mayan (to /mnt/sharepoint/). However I get permision errors (error 13 permission denied) 

Iv'e changed permissions to 777, owner to root, mayan and web Iv'e even changed the group to mayan.

I cannot find any specific help in sharing mounted folders to the applicance. I can feel im close to solving this, but would appreciete any assistance. 

 

Thanks  

 

Forum: 
Tags: 
Jeremy Davis's picture

I'm somewhat biased (prefer CLI at the best of times) but IMO troubleshooting issues is best done via CLI. It's also worth noting that as a Linux only user, CIFs (or anything Windows related) is not really my strong suit....

You've likely already tried some (perhaps all) of this, but I'll step through what I would do via CLI just in case. Don't use Webmin for this as it doesn't have a proper interactive shell. So either do this via SSH, local terminal (if running in a VM) or Webshell. Personally I prefer using an SSH session as it provides a pretty native interface and things such as copy/paste work exactly as I expect, but YMMV.

So first up, I would double check that the share is mounted ok:

mount | grep sharepoint

Then double check the contents and who owns it:

ls -la /mnt/sharepoint

It's often a good idea to check as the user in question ('mayan' in this case). Be sure to move to the system root dir (i.e. '/') first to stop a permission error when running as a non-root user while in root user's home dir; '/root'.:

cd /
su - mayan -s /bin/bash -c "ls -la /mnt/sharepoint"

That covers what you've already done essentially. However you note that you even tried setting permissions as 777 (read, write and execute to the whole world) makes me think that perhaps the permissions issue may be on the CIFs host, rather than the Linux side of things?

It may also be worth restarting Mayan?

Also, perhaps another approach may be to mount the CIFs share within the Mayan dir (IIRC /opt/mayan or something similar) i.e. somewhere where the mayan user already has access? Although mouting as root might also cause issues? So perhaps you can mount as the mayan user (to somewhere the mayan user has access). IIRC you do that by specifying a 'uid=xxx' option when mounting. (The 'xxx' needs to be replaced with the actual UID of the mayan user).

Garreth's picture

Hi Jeremy,   Thanks so much for taking the time to help. I unmounted the previous share, mounted in /opt/mayan and problem is solved. Thanks for pointing that one out, didnt think of changing the mount point.  Thanks again. 

Add new comment