Adam's picture


I am also having the same issue mentioned in the comment on this thread. When running 


I get the following error: 

INFO [tkldev-setup]: Downloading bootstrap-buster-amd64
File 'bootstrap-buster-amd64.tar.gz' already there; not retrieving.

File 'bootstrap-buster-amd64.tar.gz.hash' already there; not retrieving.

INFO [signature-verify]: Verifying GPG signature
gpg: Signature made Sun Mar  8 10:37:48 2020 UTC
gpg:                using RSA key F190A48B54DC56B2C7F24DCBAC5EB00493E5BC1C
gpg: Can't check signature: No public key
FATAL [signature-verify]: /turnkey/fab/bootstraps/bootstrap-buster-amd64.tar.gz.hash GPG verification failed


Which looks to be the same error reported in this github issue.


Any ideas on anything try / troubleshooting steps. 

Jeremy Davis's picture

Initially I thought that was a bit weird!? As your posted output notes, it uses the "signature-verify" script to confirm that the files are appropriately signed (signature-verify comes from buildtasks).

It should check for the key, and if not found locally, download it, either via Ubuntu key server or fall back to downloading from the website.

However, the v16.x key wasn't actually available via the website URL! I have just fixed that (and for v17.x too), so it should work now...

Please re-run and let me know how you go.

If it does work ok, then hopefully other issues you may hit should be covered by that thread you link to. Please do not hesitate to post if you hit other issues and/or need more detail/assistance.

FWIW once you have it all set up and working, you should be fine. But until then, as we're currently in the process of transitioning to v17.0, there is a risk that new changes I push may break the initial setup of v16.x TKLDev.

Drew's picture

I still get the same error as Adam with 16.1. It looks like the public key was successfully downloaded, though:

root@tkldev ~# gpg -k
pub   rsa4096 2021-08-04 [SC] [expires: 2041-07-30]
uid           [ unknown] TurnKey GNU/Linux Bullseye Images (GPG signing key for TurnKey Linux Bullseye Images) 
sub   rsa4096 2021-08-04 [S] [expires: 2041-07-30]
Jeremy Davis's picture

That's the key for the upcoming v17.0 release (based on Debian Bullseye)! You need the one for Buster (the basis of v16.x).

I suspect that you got that one because we're in the process of transitioning and the 'master' branch of Buldtasks now has the Bullseye key. You need to check out the 16.x branch. I.e.:

cd buildtasks
git fetch origin
git checkout 16.x
Drew's picture

Thanks, I saw you had switched common and cdroots to 16.x in the linked thread but missed that buildtasks also needs it. I did run into a different error when building an appliance (below) after updating the branches:

setting apt proxy settings...
updating package lists...
Get:1 buster/updates InRelease [65.4 kB] 
Get:2 buster InRelease [122 kB]        
Ign:3 buster-security InRelease
Ign:4 buster InRelease
Get:5 buster-security Release [3857 B]
Get:6 buster Release [3830 B]
Get:7 buster-security Release.gpg [833 B]
Get:8 buster Release.gpg [833 B]
Get:9 buster/main amd64 Packages [31.0 kB]
Get:10 buster/updates/main amd64 Packages [311 kB]
Get:11 buster/updates/main Translation-en [168 kB]
Reading package lists... Done                   
N: Repository ' buster InRelease' changed its 'Version' value from '10.3' to '10.11'
E: Repository ' buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
N: This must be accepted explicitly before updates for this repository can be applied. See apt-secure(8) manpage for details.
Traceback (most recent call last):
  File "/usr/lib/fab/", line 34, in 
  File "/usr/lib/python2.7/dist-packages/", line 388, in main, args)
  File "/usr/lib/python2.7/dist-packages/", line 261, in run
  File "/usr/lib/fab/pylib/", line 129, in main
    installer.install(packages, ignore_errors)
  File "/usr/lib/fab/pylib/", line 276, in install
    self.chroot.system("apt-get update")
  File "/usr/lib/python2.7/dist-packages/", line 80, in system
  File "/usr/lib/python2.7/dist-packages/", line 56, in system
    raise ExecError(command, exitcode)
executil.ExecError: non-zero exitcode (100) for command: chroot '/root/tkl-wp/build/'  'sh'  '-c'  "env -i  'TERM=xterm-256color'  'AMD64=y'  'DEBIAN_FRONTEND=noninteractive'  'HOSTNAME=tkl-wp'  'WEBMIN_FW_TCP_INCOMING=22 80 443 12320 12321 12345'  'FAB_ARCH=amd64'  'DEBIAN=y'  'FAB_HTTP_PROXY='  'DEBIAN_PRIORITY=critical'  'HOME=/root'  'RELEASE=debian/buster'  'PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/bin:/usr/sbin'  'CODENAME=buster'  'LC_ALL=C'  'DISTRO=debian' apt-get update"
make: *** [/usr/share/fab/ build/stamps/] Error 1

However, I can build successfully on 17.0rc1, so I'll use that and stop pestering you for support. Thanks for the quick responses and all the work you put into this!

Add new comment