Witzker's picture


I have updated Jelly fin as described here:


Everything was Fine, Then I mounted 2 Folders from Synology & created 2 music libraries = Still Fine

rtc/fstab content:

/dev/mapper/turnkey-root    /    ext4    errors=remount-ro    0    1
/dev/mapper/turnkey-swap_1    none    swap    sw    0    0 /mnt/music nfs rw 0 0 /mnt/AudiobooksTag nfs rw 0 0

The Folders / subfolders / files are shown in /mnt

After scanning The libraries and connecting via Finamp on iPhone = still fine

Then I edited many folder names on Synology

In the evening, I connected via finamp & nothing was shown.

The i looked at the server on ESXi and found This ( Pls see  Screenshot_VM_Media_server.jpg 

Then I logged In With Putty and Tried to start Jellyfin Result: Pls see  Screenshot_putty_jellyfin.jpg

Also Webmin is not reachable

I powered off the server and restarted again but same result.

Pls help to get it running again

many THX



Jeremy Davis's picture

That is very strange!

I might start at the end of your post. The fact that Webmin is not working, as well as your noted Jellyfin issues, does suggest that there may be some serious system wide issue.

Where/how are you running your TurnKey Mediaserver? E.g. bare metal? VM? (sorry if you've already told me elsewhere). Ultimately, it shouldn't really matter where/how you have it running, but it may be useful info. If it's a bare metal install, then failing hardware is a possibility. It's also a possibility even if you are running a VM, although it's unlikely that there wouldn't be other issues noted (as physical hardware issues would likely also cause issues on the host).

Regardless, check to see if your root volume is mounted read only (a common sign of a failing HDD):

mount | grep ' / '

Judging from the output you shared, if it's still mounted read/write, that should return this:

/dev/mapper/turnkey-root on / type ext4 (rw,relatime,errors=remount-ro)

If not, then it will be more like this:

/dev/mapper/turnkey-root on / type ext4 (ro,relatime,errors=remount-ro)

Note the first 2 letters within the parenthases; 'rw' (read/write) or 'ro' (read-only).

one other thing to check is free disk space. I think it's probably unlikely that it's run out of free space, but perhaps?

df -h /

I'd also be interested to see some more info about Webmin's status, as well as it's stunnel service:

systemctl status webmin stunnel4@webmin

It might also be useful to get the most recent (40) lines for both services from the journal:

journalctl -b -u webmin -u stunnel4@webmin | tail -40

Moving back to the top of your post and Jellyfin specifically, your first screenshot shows that something caused Jellyfin to stop (well restart strictly speaking).

Hopefully you might be able to determine why by running this:

journalctl -u jellyfin

Then scroll through the output until you find that event. Ideally copy/paste the relevant lines into a new post (please include a few lines on either side of the restart).

If you have an idea of when the issue was, you can specify the Journal timeframe that you want to view. E.g.:

journalctl -u jellyfin --since "2022-09-02 17:15:00"

Or with between times/dates:

journalctl -u jellyfin --since "2022-09-02 17:15:00" --until "2022-09-03 00:00:00

Once you've worked out the timeframe that the restart occurred, if the Jellyfin journal itself doesn't provide enough info, it might be worth checking what else was happening on your system around that time. So rerun the 'journalctl' command, but this time, use the '--since' and '--until' switches to limit the timeframe to say 2 minutes either side of the Jellyfin restart timestamp. E.g. assuming that the "Jellyfin stop" occurred at 2022-09-02 19:17:10, try something like this:

journalctl --since "2022-09-02 19:15:10" --until "2022-09-02 19:19:10"

Please post back that info and I'll try to give you a hand decoding what went wrong.

Last thing: please note, that unless you have set the timezone of your server, the times shown by the journal will be in UTC.

Moving on to your second screenshot, that suggests that either /usr/lib/jellyfin/bin/jellyfin-web doesn't exist. Or if it does, it's not in the expected format. Or perhaps Jellyfin doesn't have permission to access it now?

First step is probably to have a look what is going on with that path. I suggest simply listing it:

ls -la /usr/lib/jellyfin/bin/jellyfin-web

I assume that that path is provided by the 'jellyfin-web' package. So double check that is still installed (and which version if so):

apt policy jellyfin-web
Witzker's picture

Many THX for taking care!

You mentioned Disk space

root@mediaserver ~# df
Filesystem                              1K-blocks       Used  Available Use% Mounted on
udev                                      1004976          0    1004976   0% /dev
tmpfs                                      204196      14900     189296   8% /run
/dev/mapper/turnkey-root                 17369872   16505436          0 100% /
tmpfs                                     1020976          0    1020976   0% /dev/shm
tmpfs                                        5120          0       5120   0% /run/lock
tmpfs                                     1020976          0    1020976   0% /sys/fs/cgroup 11614123392 9653552384 1960452224  84% /mnt/AudiobooksTag         11614123392 9653552384 1960452224  84% /mnt/music    11614123392 9653552384 1960452224  84% /mnt/Audiobooks
root@mediaserver ~#

SORRY I don know how to post a Picture here !!?

But a newbie question

Does the mounted folder from Synology use disk space on the VM?

Jeremy Davis's picture

Yep, you've run out of free space:

/dev/mapper/turnkey-root                 17369872   16505436          0 100% /

FWIW if you use the '-h' switch it will be in human readable format (e.g. MB/GB/etc) and if you just, you can just see the usage of the root volume ('/') explicitly. I.e. 'df -h /'.

Posting pictures is a bit of a pain and is not intuitive at all. You need to upload them somewhere first (you can edit your first post and attach them there if you want) then include them in your post via the URL. A pain... But IMO it's better to post text anyway when you are showing output.

The remote mounts don't use local space. But Jellyfin will generate a fair bit of metadata relating to the remote files, plus it will locally cache temp data such as transcoded videos and other stuff like like that.

To work out what is taking up all your space, I suggest trying to clear a little free space and install 'ncdu':

apt clean
apt update
apt install -y ncdu

Hopefully the 'apt clean' clears enough space to install 'ncdu' (it's a very small tool). Then run that like this:

ncdu -x /

That will sort the contents of your root volume (only; because of '-x' switch it won't check files in any of the remote mounts) in order of size (directory contents or file size). Please do be careful deleting stuff. Generally you should be ok to delete cached files (i.e. the contents of /var/cache subdirectories), log files (in /var/log). Obviously, you own all the files in /root. Generally don't touch files in /usr (with the exception of /usr/local). Please feel free to ask if you are unsure.

I notice that you are using LVM too, which is good. If you wish to increase the root volume size of your Mediaserver, please see this old blog post. It's quite dated, but still totally relevant.

If you need any further info or advice, please ask.

Witzker's picture


As I mount the musik from synology I do not need the file sever..... only Jellyfin!

Is it easy to uninstall everything that only working Jellyfin remains? 

Or better start from scratch with core? 

But how to install Jellyfin there without Docker?




Jeremy Davis's picture

You could just install Jellyfin on Core via their official Debian repo. That's essentially what we do. Although we do go a little bit further. E.g. we put the gpg key in /usr/share/keyrings/ and explicitly note it's location in the apt sources.list. We also pin Jellyfin (although now I look at that, we should probably make that 'jellyfin*' rather than 'jellyfin').

Add new comment