Mark U's picture

I am running a clean installation of VirtualBox (6.1.38) on Windows (W11 Home 64-bit) and have imported the TurnKeyLinux XOOPS VM (16.1-buster-amd64) but am unable to install VBoxLinuxGuestAdditions (supplied with VirtualBox download), getting the following error messages:

/opt/VBoxGuestAdditions-6.1.38/bin/VBoxClient: error while loading shared libraries: : can not open shared object file: No such file or directory.

            Remedied as ‘root’ by:

               apt update

apt install libxt6 libxext6 libxmu6 (X11 components ?)

Kernel headers not found for target kernel 4.19.0-22-amd64. Please install them and execute /sbin/rcvboxadd setup

Remedied as ‘root’ by:

apt install linux-headers-$(uname -r)

apt install gcc make perl

/sbin/rcvboxadd setup

On reboot VBoxGuestAdditions are not mounted so I reran :

               sh ./

               which then gives this error:

Failed to connect to bus: No such file or directory

I’m stuck. Help please. :)

(I also tried building from the 17.1 .iso but got the same errors).


Jeremy Davis's picture

FWIW dbus is a desktop messaging service which many desktop applications use to talk to each other and/or the system. Historically (as the name suggests) it was only required on desktop system and had limited value on a server, hence why we don't include it by default. As systemd continues to take over everything, more and more things expect dbus to be available, so we may need to rethink that at some point (FWIW we did discuss it for the latest release, but decided not yet).

To install dbus should be pretty easy:

apt update
apt install -y dbus dbus-user-session

Hopefully that should be enough to get you going. If you still continue to have issues, please let me know and I'll have a look myself.

Mark U's picture

Thanks Jeremy. I tried this but am now getting error messages relating to update-initramfs, e.g.

/usr/share/initramfs-tools/scripts/live-bottom/25autologin : Can’t open /scripts/functions

Elsewhere, others with similar messages found a cure by reinstalling some packages –

apt-get install –reinstall initramfs-tool

apt-get install –reinstall findutils

update-initramfs -u

but this didn’t seem to help here.

Jeremy Davis's picture

Firstly, there is a new v17.1 release of our XOOPS appliance. It's only available as an ISO at this point, so you'll need to install it to a new VM (rather than import it - I suggest at least 2x vCPUs, 2GB RAM and 20GB minimum root volume). But if you want a newer OS (with newer versions of other software and a longer time until it reaches EOL) then I suggest starting again with that. Apologies that I didn't mention that yesterday. I still haven't finished so they're not "officially published" yet - I still need to upload the changelogs and do a blog post. But the ISO is good to go if you're interested.

Also, (something else I perhaps should have asked about sooner) I'm curious what you're using your server for that would require installation of "VBoxLinuxGuestAdditions"? AFAIK, it's only needed if you plan to pass through USB devices?! Everything else should "just work" without dedicated VirtualBox extensions. We do pre-install the VMware extensions, but they actually include VMware specific drivers that give better disk and network performance. I'm almost certain that that's not the case with VirtualBox (hence why we don't make it easier to install them).

Having said that, perhaps there is something that I'm missing? If there is value in making it easier to install VirtualBox guest addons, then perhaps we could write a simple helper script to save future users some headaches?

Seeing as it's a headless server, personally, I'd run the server in "headless mode" (use the GUI for initial setup, but once installed, relaunch in headless mode so yuou don't have the VM window cluttering up your desktop) and interact with your server via SSH/SFTP/SCP. So even though it's running locally, you're interacting with it as if it were any other remote headless server.

As you're running Windows, you'll need to install client software to do that. E.g. tools such as OpenSSH (SSH), PuTTY (SSH), WinSCP (SSH/SFTP/SCP) and/or Filezilla (SFTP/SCP)) and/or Webmin (HTTPS on port 12321).

If you'd rather keep going with v16.1, that message "/usr/share/initramfs-tools/scripts/live-bottom/25autologin : Can’t open /scripts/functions" can safely be ignored. It doesn't actually cause any issue (beyond the message). It's just left over cruft from the live ISO functionality (all alternate build types are constructed from the ISO) and IIRC it should be fixed in the new release.

If you don't want to just ignore the message, you could just delete that file. Actually, you could delete all of the "live-*" directories in /usr/share/initramfs-tools/scripts. I.e.:

rm -r /usr/share/initramfs-tools/scripts/live-*

I anticipate no issues, but as per always; create a backup and/or snapshot of your VM before doing anything of any significance such as this (that might cause a whole world of pain if you do a typo).

Good luck with it and I'd be interested to hear which way you go and why.

Mark U's picture

I‘m using VBox as a development environment for rapid prototyping of bespoke Content Management Systems based on Drupal/XOOPS frameworks. It is ideal in this respect as machines can be saved/restored to a clean point with ease (a daily occurrence) and shared with other developers if needs be. I’m perfectly OK with TKL being ‘headless’ it’s just what I need operationally.

WRT GuestAdditions :- I can work around the absence of a ‘shared folder’ by using Webmin to upload/download files, but ‘shared folders’ are simpler. Other Guest Additions features such as ‘cut’n’paste to shared clipboard’ I find useful although perhaps not essential. Some would find the ability to connect USB hard drives etc. necessary – it all depends on what you’re building.

A key issue here is that VBox users are often accustomed to installing GuestAdditions routinely …. and when it goes wrong we despair! This might put a lot of people off using TKL appliances (any of them)  in the first place. But you’ve made me think twice - GuestAdditions aren’t always essential and I suppose might even compromise the TKL stack. I’ll proceed by experimenting with the 17.1 ISO minus GuestAdditions and let you know how I get on.

The option of an install script for those who need GuestAdditions sounds very sensible. It would also make sense to update the ‘Appliance Installation Tutorial with VirtualBox (New)’ notes with some GuestAdditions guidance.

Thanks for all your help, it’s very informative.

L. Arnold's picture

I tried for a while to get Virtualbox working well with TKLBAM but could not get a good restore (small simple firewall/router)

I circled back around and thught perhaps if I opened the DMZ to that specific NAT/IP address...  I tried that and voilà it worked.

This specific router is quite limited.  I can assign one internal IP to the DMZ.   Can do a bit more with port routing but makes for a tangled web with multiple servers.

The good thing though is I can move servers in for archive purposes and turn them off in the web.

Was searching for VirtualBox headless and came to this post.  Thought it might be relevant to share my experience anyway  (not headless yet).

Jeremy Davis's picture

My suspicion is that it might be a builtin firewall in your router? I know mine has that by default.

Regardless, it's probably a good idea to have a locally hosted server in a DMZ. It the worst case and a malicious actor hacks your server, that shouldn't be able to break into your LAN.

Add new comment