Vincent Elliott's picture

Hi,

I have tried to install both the CORE and MONGODB v16.1 appliances running under libvirt and the installation failed everytime when trying to install grub on an LVM disk.

The error reported is a "fatal error" irrespective of selecting any of the provided options except "Manually specifying the drive...".

This issue I have found is that grub defaults to trying to install to /dev/mapper irrespective of the selected target except as noted above "Manually specifying...".  In my instance I had to manually specify "/dev/vda" and then it worked without further issue.

As an asides, the hostnamectl command is missing and attempting to change the hostname from the confconsole menu does nothing...

Thanks again for the great effort in creating and making these applicances available.

Best regards and keep safe,

Vincent

Forum: 
Jeremy Davis's picture

What you note is a known issue with some VMware platforms, but I have not hit those issues on KVM, Xen or VirtualBox. I'm not sure why, but it seems that for some reason grub trips up on the drives as presented by some VMware virtualisation?!

Did you restart after changing the hostname? It definitely should work!?

Vincent Elliott's picture

Hi Jeremy, I am running KVM/QEMU (libvirt) on Debian Bullseye. I did restart after changing the hostname using confconsole... the change was not reflected either from the hostname command or in /etc/hosts. I also noticed that the VM did not send the hostname during the DHCP request.  I had to create a static ip address for it using "virsh --connect=qemu:///system net-edit default". Hope this helps your resolution. Vincent

Add new comment