TKLBAM Restore phenomenon

Michael Maass's picture

Hi, 

I had the romantic idea to restore a Redmine 12 backup from TKLBAM into a Redmine 14.1. installed on EC2. But either the changes between the Redmine 12 and 14 Appliances have been to large or I am missing out something on the EC2 part. 

The last part of the TKLBAM Log: 

("No usable temporary directory found in %s" % dirlist)) 
IOError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/usr/share/webmin/tklbam'] 
Exception AttributeError: "'TempFile' object has no attribute 'pid'" in <bound method TempFile.__del__ of <closed file '<uninitialized file>', mode '<uninitialized file>' at 0x7f9720f256c8>> ignored

suppose I have to export/import the Content on the Redmine Level of things?

Anybody with an explanation? Any other Idea on howto migrate the content between the two instances? Maybe somebody has successfully done that before? 

Regards

Michael Maaß

Jeremy Davis's picture

TKLBAM works really well in some scenarios... But requires some tweaking in others.

As a general rule TKLBAM works awesome on the same version and pretty good to awesome within a major version (e.g. 14.0 -> 14.2). Even between major versions (e.g. 13.0 -> 14.2) it mostly works fairly well, although there are manual tweaks required. And the further the version difference, the more work it's likely to be.

It's not documented per appliance as well as I'd like, but there is a doc page that gives a suggested workflow and covers some of the issues migrating. It's not exhaustive though and YMMV.

Having said that, the error you're reporting doesn't sound right?! It looks like it can't find any temp directory in the new instance?! I'm pretty sure that's not right?!

Re reading your post, it sounds like you may have tried launching the backup directly from the Hub?! It certainly shouldn't choke with what you've reported. But OTOH it's unlikely to produce a fully working site/server without manual intervention (as noted above).

As noted in the doc page, even in a "worst case" scenario (e.g. you do a full manual data migration), tklbam can still be really handy to migrate all the data.

If you're game, I'm happy to help as much as I can. If so, I suggest that you launch a new server (EC2 or local VM, etc) and try doing a manual restore once you've set it up. And see if you get the same error. Expected behaviour would be a successful restore, but redmine broken afterwards.

FWIW I helped someone else with a v12.1 -> v14.1 migration a while ago that ended up ok. We upgraded Redmine to the latest as part of the process and a couple of plugins he was using were no longer supported. So he had to resolve that, but otherwise it was all good.

Post new comment