First time user of Turnkey apps as I have had issues with Bitnami. I installed the Dokuwiki V16.0 app (VMDK) on VMware Player 16 on Windows 10 and set the passwords as requested by the prompts, but when I attempt to do the dokuwiki login it fails continuously. I use admin as username and the password I configured but still get "Login incorrect" message. I've re-installed this three times now as sanity check but I cannot login. Any suggestions?



Jeremy Davis's picture

Hi there. Thanks for giving TurnKey a try and sorry to hear of the frustration you've experienced off the bat. :( Thanks too for reporting the issue you've hit.

So assuming that you can log into the console ok, and it's the DokuWiki web UI that you can't log into, I tested that locally.

I downloaded the v16.0 appliance (as an LXC container rather than VM, but it shouldn't make any fundamental difference) and set a password of "TestPassword01" (no quotes). I then browsed to the webUI (I just browsed to the plain HTTP site via IP address, but again, that shouldn't matter) and clicked the "Log in" text link in the top right corner. I then used the username "admin" (no quotes) and the password I set (as per above) and it "just worked" as per my screenshot below:

turnkey dokuwiki screenshot

So, in an effort to try to understand why you might have hit this issue, can you please let me know if you are using a US (or "US International") keyboard?

The other thing that may be an issue, is perhaps you have used some specific special character in your password that DokuWiki does not accept? It's not something I've ever hit before with DokuWiki, but I have hit similar issues with some other appliances with characters such as parenthesis - '(' & ')'. Also quotes (single and/or double) and doallr signs may also be problematic.

If you want to test that out, please try resetting the password (this time try with just uppercase, lowercase and numbers) from the commandline, like this:


If that works and your original (non working) password did contian some special characters, please let me know which special characters you used and I'll do some more testing and either fix it; or restrict the characters which can be used in DokuWiki passwords.

Add new comment