Brian Bonnell - BEB Consulting Services's picture

Our Observium Container is show draw errors for every graph. It is collecting data but not generating graphs.


Jeremy Davis's picture

Hi Brian. Welcome to TurnKey and sorry to hear that it's not working well for you right now. Apologies too on my slow response. I've been unwell.

Could you please share a bit more info? Is this a server you've had running for while that has just stopped creating graphs? Or is this is a new install? Either way, could you please confirm the version that you are running. If unsure, run:


Also when you say "show draw errors" could you please be more specific? Is there an error message displayed? If so, what does it say exactly? Perhaps you could upload a screenshot somewhere?

In the meantime, I'll gamble on this being a new server of the most recent release (v17.1) and my first guess is a missing (new) dependency. I've just had a quick look at the Observium install docs, particularly the dependencies and compared them against the manifest of the current appliance.

There isn't anything missing that I would expect to cause an issue similar to what you've reported. Having said that, there are still some missing deps none the less. So please install them like this:

apt update
apt install -y php-bcmath php-mbstring php-curl
systemctl restart apache2

As I said, I wouldn't expect any of those to cause the issue you note, but perhaps they are somehow involved?

Look forward to further info from you.

Federico's picture

I do have the same error. I try to update to the latest version and also try did    Graphs not showing in Observium - Stack Overflow   However still no graphs and this legend on every device     Device not yet polled This device has not yet been successfully polled. System information and statistics will not be populated and graphs will not draw. Please wait 5-10 minutes for graphs to draw correctly     root@observium ~# turnkey-version turnkey-observium-17.1-bullseye-amd64    
Jeremy Davis's picture

Thanks for your report Federico. Did you install the missing dependencies that I noted in my previous post and then restart Apache?

Also, do you have a link to the stack overflow post you're referring to?

[edit] I've looked through a few "Observium - Graphs shows no data", etc and none of them look relevant to me.

Finally, I'm not particularly familiar with Observium, so if you could step me through how I can recreate the issue on a fresh v17.1 Observium instance, then I'm almost certain that I'll be able to fix it!

Federico's picture

Jeremy.   Thank you so much for the reply, I follow all your steps and reboot and nothing. but I tried to download the old version the 16 and this one is working with no problem.   What I did is to install the old one and update the observium package and so far it's working fine, after the install I saw all the icons "funky" nothing that an CTRL+F5 can't solve.    
Jeremy Davis's picture

Thanks for the update and glad to hear that you've found a workaround (by installing the older release and updating it).

However, for me to be able to fix the current release, I need to work out what the problem with it is. To work out the problem, I need access to a server where the problem is occurring. Perhaps it's really easy to recreate the issue, but I have no idea! I'm completely unfamiliar with Observium - so I have no idea how to recreate the problem.

Could you please step me through recreating the problem? I am very familiar with the TurnKey install and firstboot processes, so I don't need details on any of that part. Starting from first log into the Observium UI as admin, what do I need to do to display the broken graphs/error messages?

The more specific, the better, but even just a vague idea would be useful!

Add new comment