Raymond Sullivan's picture

Is anyone else having this issue?

I am deploying an Amazon EC2 cloud server for the LeanTime app. The issue I am having is the browser does not recognize this specific route so far: http://123.456.789.ABC/users/editUser/#/


This is a page where I can edit the user credentials. The browser responds with an HTTP 500 error.

Thanks in advance!

Jeremy Davis's picture

Hi Raymond, welcome to TurnKey.

Apologies on my slow response, I've been unwell and am still catching up on the backlog.

Thanks for reporting the issue.

Leantime is a PHP app and a 500 error on a PHP app suggests a PHP error of some sort. It could be a bug in Leantime, or a bug in TurnKey (missing PHP dependency? missing or incorrect pre-configuration). Usually those sort of bugs should show up in the Apache logs (and the journal). You'll find the Apache logs in /var/log/apache2 (or view in journal with 'journalctl -u apache2').

Regardless, I just fired one up myself and had a quick look into it. Whilst it turns out that the error was logged by Apache, but just as a 500 error and no further detail.

However, I did a bit of googling and it appears that it was actually a bug in Leantime. It was fixed, but not included in a release until after we did the last release of our Leantime appliance.

As it's been fixed upstream, I was going to just suggest updating to the newer version. However, when I tried, it failed because the newer version of Leantime, requires a newer version of PHP than what we have available via official Debian repos.

So ultimately what I'll do is update the Leantime appliance and include newer PHP. I'm not 100% sure when that will be ready though, so in the meantime I'll develop a script for updating PHP to 8.1. I'll also document the exact steps to do the Leantime update. Hopefully that will be done within the next few days.

In the immediate meantime, you can work around the issue by running this command (as root - or prefix 'sudo'):

sed -i.bak "\|^[[:space:]]*'password'|s|=|=>|" /var/www/leantime/src/domain/users/controllers/class.editUser.php

After you've run that, then restart Apache:

systemctl restart apache2

I'll be back ASAP with something soon hopefully.

Raymond Sullivan's picture

thank you for getting back to me. I am sorry to hear about your wellness, I am praying for you. I applied the work around you provided and it works great so far. Again, thank you so much, and please keep me posted when you do the overall update.

Jeremy Davis's picture

Thanks for your kind words Raymond.

I'm glad to hear that the work around worked for you too. I'll try to keep you posted. :)

Add new comment