Abkrim Mateos's picture

I can't access to my server with Turnkey appliance after recreate SSL Certificate (Webmin)

I can deactivate force acces to https for see and correct problem.


¿Is it possible?


Error with https





Jeremy Davis's picture

Hi Abkrim. Apologies on my really slow response.

I've had my head down trying to push the new v15.0 release out the door. Having said that, I have posted on the forums since your post, but must have just missed it. Sorry about that.

What exactly are you trying to do?

If you are trying to create a "proper" (i.e. not self signed) SSL certificate for your server then the way to do that is via our CLI tool, Confconsole. It has support for creating free "Let's Encrypt" certificates. Please note though that the version included in v14.2 has a bug. The workaround for the bug is noted in a comment.

That will generate a Let's Encrypt SSL cert which all https interfaces should use from here on in.

Unfortunately though, it's likely that the steps you have taken have broken the default Webmin config. So you'll need to fix that. I forget exactly the steps, but you'll need to edit the Webmin server config file and disable SSL (Webmin is served behind Stunnel - which provides SSL for both Web Shell and Webmin). I'm pretty sure, just setting ssl= in that file should do the trick. You'll also need to restart Webmin. So this should do the trick (from the commandline):

sed -i "s|^ssl=.*|ssl=|" /etc/webmin/miniserv.conf
service webmin restart

If that still doesn't work, please post your full /etc/webmin/miniserv.conf file (ideally please copy/paste the text) and I'll try to help out. You can get the current config like this:

cat /etc/webmin/miniserv.conf
Abkrim Mateos's picture

I've a very older Turnkey Linux (I think 4 years ago or more)


On Confconsole I don't menu with Let's Encript...

  • Networking
  • Reboot
  • Shutdown
  • Quit

Apreciate help. Is possible upgrade to a fresh VPS pro this...




Yo solo se que no se nada...

Castris Hosting

Jeremy Davis's picture

If you aren't sure, then from the commandline run:


That will return a string like this:


E.g. a 64 bit v14.1 lamp appliance (based on Debian Jessie) will return:


Assuming you have v14.0 or v14.1, then you're in luck. You'll just need to follow the instructions in the upgrade confconsole section of the docs.

If you have a v13.x (or earlier) appliance, then you are out of luck. In more ways than one! It's time top upgrade ASAP as you will no longer be getting security updates! If you need some pointers on that process, let me know.

Add new comment